Jump to content

Giovanni Gigante

Members
  • Content Count

    2
  • Joined

  • Last visited

About Giovanni Gigante

  • Rank
    Nuovo utente
  1. Giovanni Gigante

    traffico smtp sparisce misteriosamente

    Rettifica. Paranoia telecom ingiustificata. Viene fuori che nel DNS del dominio, il record MX conteneva un IP numerico anziché (come prescritto dalle RFC) un FQDN. Cosa che apparentemente funziona lo stesso "quasi" sempre, ma evidentemente non abbastanza. Corretto questo, sono arrivate anche gran parte delle mail sparite. L'apparente somiglianza tra le mail sparite era, a quanto pare, accidentale. Lezione interessante: quando uno ha esaurito gli strumenti cognitivi, scivola nelle teorie cospiratorie. Thanks and sorry for the noise. gg
  2. Ciao a tutti, sto uscendo di testa su un problema che non riesco a risolvere, forse qualche anima buona mi può dare una dritta. Un mio serverino, da anni connesso alla rete tramite una ADSL "impresa semplice" telecom con IP statico, ha un server SMTP (per l'esattezza exim4 su debian), che finora avevo usato molto saltuariamente ma che da qualche giorno ho iniziato a usare per davvero, per le mie piccole esigenze, avendo chiuso qualche casella che avevo altrove. A farla breve, il tutto funziona apparentemente bene, in entrambi i sensi, ma una certa parte di email in arrivo misteriosamente non viene ricevuta. Con questo, intendo dire che non ce n'è proprio traccia, nei log di exim o in qualunque altro posto. Svaniscono in un buco nero prima di arrivare da me. Ho anche provato a piazzare un packet sniffer sulla porta 25 giusto per essere sicuro, ma niente. Delle mail in questione non c'è notizia. In particolare, non arrivano mail che provengono da fonti come apple, facebook, paypal, e alcuni mail list server (tipicamente, mail di conferma di iscrizione o di cambio di indirizzo, notifiche, cose del genere). Le altre arrivano. Sono due: o il mio dominio ha qualcosa che lo fa reputare schifoso dai MTA dei soggetti in questione, o qualcuno si mangia i messaggi strada facendo, forse pensando che sia spam (l'unica cosa in comune che hanno queste mail, mi sembra, è che contengono molte URL nel corpo). Per scongiurare la prima ipotesi, nei limiti delle mie conoscenze non approfonditissime, ho fatto un check completo del mio server SMTP usando il sito mxtools, ma sembra tutto regolare. Il mio IP non si trova in alcuna blacklist. Nessun problema particolare viene imputato al mio server; per scrupolo, ho risolto anche tutti i problemini minori che pure non dovrebbero entrarci (diminuita la lentezza, attivato TLS, fatto coincidere l'host riportato da HELO/EHLO con il record rDNS) ma anche così, il mistero persiste. Non ho un record SPF sul dominio, ma a quanto ne so non dovrebbe fare alcuna differenza per le mail in ricezione da altre fonti. Capirei se non funzionasse nulla, ma il fatto che funzioni tutto *eccetto* alcune sparizioni misteriose mi lascia estremamente perplesso. A questo punto non so più dove sbattere la testa. È possibile che la telecom abbia un proxy nascosto che distrugge il traffico SMTP in entrata che a suo delirante giudizio non gli piace? Se sì, ci si può fare qualcosa? Se no, cos'altro potrebbe essere la causa di questo problema? Grazie a chiunque potesse aiutarmi. Giovanni
×