Jump to content

xnavigator

Members
  • Content Count

    290
  • Joined

  • Last visited

  1. mio dio... google webmaster tool mi mostra un tempo di caricametno di oltre 7 sec per questo sito in lingua... lo stesso sito in lingua originale sullo stesso server i tempi sono normalissimisi sui 2sec
  2. HMM credi che questo risolverbbe i problemi? cioè il server proxy nel paese in america poi dovrebbe inoltrare le chiamate al mio server in europe e rispedire i contenuti al client in america... dici che migliorerebbe le cose? edit: bhè se potesse anche implementare dei sistemi di caching, cosi da non dover ricevere ogni volta le pagine dal server in europa bhè credo che si potrebbe funzionare alla grade... anche se non avrei idea di come configurare nginx però sarebbe un ottimo metodo credo!
  3. si ma già ora se mi collego dall'europa i tempi di caricamento sono di 1-2 secondi al max. quindi non credo dipendi da apache
  4. non ho capito.. cioè mettendo semplicemtne nginx al posto di apache i tempi dovrebbero migliorare cosi tanto? non capisco il motivo :D
  5. allora ragazzi la questione è questa. sto facnedo un sito in 2 lingue, il server attualmetne è in europa. sul server non c'è nessun problema di prestazioni, nel senso che le pagine si caricano in un attimo (meno di 0.1s) il problema è che controllando con google webmaster i tempi di caricamento nell'altra lingua (che è attualmetne è una lingua presente in america, quindi non nello stesso continente del server) ho visto che i tempi che riporta google sono oltre 4 sec ( :cartello_lol: ) risulta chiaro che il problema è la distanza del server... come si potrebbe risolvere sto problema? la soluzione che ho pensato è creare un mirror del server per ogni lingua presente, cosi da avere un server fisico di ogni nazione che serva, il problema è che ad ogni aggiornamento del server princiaple i dati (principalemetne il database) dovrebbero essere aggiornate automaticametne su tutti i server mirror. mi sembra molto elaborato gestire la cosa cosi
  6. in effetti è proprio quello il problema =/ se sorgono imprevisiti non semplici da risolvere non è uno scherzo.. peccato... fosse windows lo aggionerei in un attimo lol
  7. allora ragazzi mi è appena giunta email dalla mia compagnia di hosting che mi dice che mi consiglia di aggiornare il kernel in vista di una nuova patch che sta uscendo. il prbolema è che sono abbastanza a digiuno di ambiente linux... e più passa il tempo e più mi ritrovo con versioni di php & mysql vecchie.. è molto complicato aggiornare tutte queste cose? dite che faccio molto prima a chiedere aiuto a qualche servizio che lo fa a pagamento oppure è meglio se mi metto e lo facci oda solo? thx
  8. spero tu sai ironico.. perchè consigliare di cambiare CPU quando ho appena detto che disabilitando la compressione ora va tutto bene è un pò da :062802drink_prv: edit: cmq mi disiscrivo dal thread, se ci sono aggiornamenti vi farò sapere :ciao:
  9. forse non ci siamo capiti non l'avevo messo io cosi. quella è la configuraizone standard di apache che molto probabilmetne è presente sul 90% delle configurazioni di apache attuali :approved:
  10. è la configurazione standard: mod_deflate - Apache HTTP Server che propone apache.
  11. Veramente non avevo settato nulla. Erano i settaggi di default del server (che mi hai preso per scemo ? oO se l'avevo io impsotato a 9 o cose del genere ci avrei pensato subito a disattivarlo) comuqnue i filtri questi erano: ##<IfModule mod_deflate.c> ##<Location /> # Insert filter ##SetOutputFilter DEFLATE # Netscape 4.x has some problems... ##BrowserMatch ^Mozilla/4 gzip-only-text/html # Netscape 4.06-4.08 have some more problems ##BrowserMatch ^Mozilla/4\.0[678] no-gzip # MSIE masquerades as Netscape, but it is fine # BrowserMatch \bMSIE no-gzip !gzip-only-text/html # NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48 # the above regex won't work. You can use the following # workaround to get the desired effect: ##BrowserMatch \bMSI[E] no-gzip !gzip-only-text/html # Don't compress images ##SetEnvIfNoCase Request_URI \ \.(?:gif|jpe?g|png)$ no-gzip dont-vary # Make sure proxies don't deliver the wrong content ##Header append Vary User-Agent env=!dont-vary ##</Location> ##</IfModule> mi sembra siano quelli consigliati da apache stesso =/
  12. ok disabilitato. provo a fare top. cpu: 0.3% FINALMETNE! mi sono messo a scaricare un paio di file e la cpu si è mantenuta sotto l'1%! non vorrei cantare vittoria cosi presto ... ma credo di aver risolto lo scrivo qui cosi chissà se qualcuno si dovesse trovare negli stessi problemi in futuro possa risolvere anche lui.. ciao
  13. vuoi vedere che il problema della cpu era questo? -.-' provo a disattivarlo
  14. ok ho contatto bobcares dovrebbero fare qualcosa a breve. Nel frattempo stavo pensnado una cosa. Se riavvio apache e poco dopo faccio top: vedo che ci sono solo 2 processi running (apache) ma che comunque stanno occupando tutta la CPU. (50% di CPU a testa) Secondo me questo non dipende dalla poca RAM. Stavo pensnado che possa dipendere dal mod_deflate per la compressione dei file di apache... Infatti se richiedo un file negli header di risposta c'è anche il "Vary: accept-encoding,user-agent". Che dite potrebbe essere questa la causa dell'utilizzo spropositato della cpu? grazie
  15. continuo a pensare che sia solo un problema di settaggi e non di hardware... se fosse un problema di risorse si dovrebbe bloccare il primo giorno, invece (ora) si blocca il 3-4 giorno dopo che apache è andato in tilt se manco questa volta non dovesse funzionare casomai chiedo l'intervento di bobcares
×