Jump to content

Portabile84

Members
  • Content Count

    47
  • Joined

  • Last visited

2 Followers

About Portabile84

  • Rank
    HT Member

Converted

  • Cosa fai nella vita?
    studio e lavoro... non sto mai fermo!
  1. Salve ragazzi, avrei bisogno di un vostro aiuto e consiglio. Vorremo attivare un server per lo storage di dati, solo condivisione per una nostra community dove, in parole povere, un utente che crea un contenuto può condividerlo con altri utenti (contenuti che vengono esportati in un unico file come fosse una sorta di zip e che, ciascun contenuto, pesa non meno di 50 mega ciascuno). La community è già presente su altro server ma la condivisione vorremo sia slegata dallo spazio del server sul quale è installata. Sapete consigliare un buon servizio di storage sul quale poter attivare il tutto? Grazie a tutti :) Giovanni
  2. Vi aggiorno sulle novità (il problema persiste ancora): ho provato a tirare su una configurazione di base su un server non in Italia ed in questo fatto puntare un dominio che ho da parte con la gestione dei dns. Il risultato? qui le email vengono recapitate correttamente, su questo che ci sta dando questo problema che non riusciamo a risolvere invece continuano ad andare in spam. Vorrei scrivervi i passi eseguiti per la configurazione del server, magari trovate qualche punto che mi è sfuggito: - OS Centos 6 Final aggiornato questa mattina da SSH - Plesk aggiornato alla 11.0.9 - Apache, Php, Mysql etc aggiornati - Da SSH ho aggiornato l'hostname - Disabilitato alcune porte del server non necessarie (tipo l'Imap ed altre) - Personalizzato il Php.ini disabilitando, tra le altre cose, la funzione mail - Creato un piano di hosting su Plesk - Qmail come ambiente per email - Aggiunto un Cliente - Modificati i dns del dominio facendolo puntare al server - Creato il dominio e reimpostate le email sul server (email prima gestite su piano email con hosting condiviso... piano convertito in gestione dns + posta) - Richiesta la registrazione dell'SPF per il dominio principale sul server che poi è anche l'hostname come impostato da SSH Fatto ciò, dopo pochi giorni, ho notato il problema alle mail in quanto non mi tornava il fatto che le email sulla rotazione dei log del dominio non venivano inviate... vado a vedere nella casella Spam di gmail (casella in cui dovrebbero venire inviati i vari log e reports del server automatici) e li dentro trovo tutto tranne la rotazione dei log. Su consiglio in questo thread, cancello le email create prima della registrazione dell'SPF, e per un attimo le email sembravano venire consegnate correttamente ma poi... nuovamente quel problema (o forse il problema non è mai sparito?) Ultime modifiche apportate sul server: aggiornamento tramite yum e nient'altro (yum update). Vedete qualcosa che non va o che non ho eseguito?
  3. Scusa la franchezza Valeriano, non fraintendermi: tradotto in italiano terra terra per uno ignorante come me? Cosa dovrei controllare? Ciò che ho fatto, l'ultima volta come tutte le altre volte, è seguire le guide ufficiali di configurazione di un server con CentOS e, l'unica cosa che ho dovuto richiedere tramite ticket, la registrazione dei PTR. Tutto ha sempre funzionato a dovere, anche con un mio vecchio dominio. La cosa strana, invece, è che con questo server le email cadono nella cartella dello spam precisando, nuovamente, che nelle configurazioni non ho cambiato nulla ma eseguito ogni passo esattamente come per gli altri. E pensare che da terzi mi è stato detto: conviene contattare i provider mail e sentire loro come mai le email vanno nello spam.... sarà l'unica strada che rimane da percorrere?
  4. Si esatto... flaggata come spam. Inviata tramite thunderbird da casella del dominio sul server, tramite smtp, a casella hotmail. Una cosa strana avvenuta quest'oggi, dovrò fare altre prove per le email: questa mattina sono iniziati ad arrivare anche tutti i log di rotazione dei domini, cosa che all'inizio non avveniva non so per quale motivo...
  5. Non potendo editare il messaggio precedente integro qui. Dal servizio su intoDNS ottengo tutte le voci in verde tranne queste: [TABLE=class: tabular, width: 99%] [TR] [TD=class: icon][/TD] [TD]Domain NS records[/TD] [TD]Nameserver records returned by the parent servers are: dns2.technorail.com. ['62.149.132.2'] [TTL=172800] dns.technorail.com. ['62.149.128.2'] [TTL=172800] dns4.arubadns.cz. ['81.2.199.73'] (NO GLUE) [TTL=172800] dns3.arubadns.net. ['95.110.220.5'] [TTL=172800] i.gtld-servers.net was kind enough to give us that information. [/TD] [/TR] [/TABLE] [TABLE=class: tabular, width: 99%] [TR=class: icon] [TD][/TD] [TD]DNS Parent sent Glue[/TD] [TD]The parent nameserver i.gtld-servers.net is not sending out GLUE for every nameservers listed, meaning he is sending out your nameservers host names without sending the A records of those nameservers. It's ok but you have to know that this will require an extra A lookup that can delay a little the connections to your site. This happens a lot if you have nameservers on different TLD (domain.com for example with nameserver ns.domain.org.)[/TD] [/TR] [/TABLE] [TABLE=class: tabular, width: 99%] [TR] [TD=class: icon][/TD] [TD]NS records from your nameservers[/TD] [TD]NS records got from your nameservers listed at the parent NS are: dns3.arubadns.net ['95.110.220.5'] [TTL=21600] dns2.technorail.com ['62.149.132.2'] [TTL=21600] dns4.arubadns.cz ['81.2.199.73'] [TTL=21600] dns.technorail.com ['62.149.128.2'] [TTL=21600] [/TD] [/TR] [/TABLE] [TABLE=class: tabular, width: 99%] [TR=class: error] [TD=class: icon][/TD] [TD]Recursive Queries[/TD] [TD]I could use the nameservers listed below to performe recursive queries. It may be that I am wrong but the chances of that are low. You should not have nameservers that allow recursive queries as this will allow almost anyone to use your nameservers and can cause problems. Problem record(s) are: 62.149.132.2 81.2.199.73 95.110.220.5 62.149.128.2[/TD] [/TR] [/TABLE] [TABLE=class: tabular, width: 99%] [TR=class: info] [TD=class: icon][/TD] [TD]Glue for NS records[/TD] [TD]INFO: GLUE was not sent when I asked your nameservers for your NS records.This is ok but you should know that in this case an extra A record lookup is required in order to get the IPs of your NS records. The nameservers without glue are: 62.149.132.2 81.2.199.73 62.149.128.2 95.110.220.5 You can fix this for example by adding A records to your nameservers for the zones listed above. [/TD] [/TR] [/TABLE] [TABLE=class: tabular, width: 99%] [TR] [TD=class: static][/TD] [TD=class: icon][/TD] [TD]SOA record[/TD] [TD]The SOA record is: Primary nameserver: dns.technorail.com Hostmaster E-mail address: hostmaster.domain.com Serial #: 1 Refresh: 86400 Retry: 7200 Expire: 2592000 4 weeks Default TTL: 3600 [/TD] [/TR] [/TABLE] [TABLE=class: tabular, width: 99%] [TR=class: warn] [TD=class: icon][/TD] [TD]SOA EXPIRE[/TD] [TD]Your SOA EXPIRE number is: 2592000. That is NOT OK[/TD] [/TR] [/TABLE] Può essere utile?
  6. Questo è un header, spero vada bene... non ne ho altri sotto mano in questo momento... Non so se può essere utile in quanto su questo header l'azienda di hosting dove si è attivato il server ha detto che non vi è nulla di strano... possibile?
  7. Ho festeggiato troppo in fretta... il problema si è ripresentato... email inviata e recapitata nella casella spam... altre possibilità di risoluzione?
  8. Ti ringrazio infinitamente, ora funziona... sarei diventato pazzo. Giovanni :)
  9. Questo non l'avevo pensato nè provato... se funziona ho un debito con te! :D
  10. Ciao netimax e grazie per il suggerimento. L'SPF, anche secondo segnalazione dell'hoster, risulta correttamente impostato e già operativo. Ti riporto il log se può essere utile:
  11. Ciao a tutti, ho attivato un nuovo server e dopo la sua configurazione, copia spudorata di quella eseguita su altro server perfettamente funzionante. Tutto ok a parte i problemi per i quali vi scrivo sperando di trovare qualche consiglio sul come risolvere il tutto: 1) Le email in uscita (sia tramite webmail che client come Outlook o Thunderbird) vanno a finire nelle caselle spam. 2) La rotazione dei file di log del Plesk non lavora, o meglio: i file vengono rigenerati giornalmente ma per qualche motivo l'inoltro automatico alla casella email impostata (gmail) non viene eseguito obbligandomi ad estrarre. Info forse utili? - L'ip non risulta presente in nessuna RBL - I dns del dominio lavorano correttamente - Plesk: 11.0.9 aggiornato al 29 Gennaio - Centos 6.3 Final
  12. Ciao DonChisciotte, si infatti ho solo scritto che un sistemista che pago segue questa parte che per me è arabo se non per qualche intervento che comunque riconosco essere basilare e non sufficiente per definirsi sistemisti... ad ogni c'è una persona che quotidianamente tiene sotto controllo i server. Sicuramente non lavorerà tutti i giorni sui nostri server, sicuramente non lavora solo per noi però il mio usare la parola quotidianamente era da riferirsi a tutto ciò che c'è dietro un server e quindi le necessità di tenersi aggiornati non solo tenere aggiornato il software di un server che quello riescono a farlo un po' tutti, basta lanciare l'update ed il pacchetto che si vuole aggiornare e non è che sia così difficoltoso... non ci vuole sicuramente un genietto dei server per farlo :D
  13. Si ovvio, d'accordissimo su questi rari casi, ma alla fine questo è il software... ricordo alcuni insegnamenti: nessun software è perfetto. Questo per dire che alcune vulnerabilità vengono individuate a distanza di molto tempo ma spesso, quelle che causano più problemi, non sono tanto quelle di questo genere ma quelle minori. Per questo dico che un aggiornamento quasi quotidiano, uno studio dei log etc. può essere più che sufficiente per stare un po' tranquilli. Poi credo che in questi casi può essere sempre utile la regola: tutto ciò che è aperto può essere un problema, ciò che è chiuso è tranquillo.
  14. Si, il fatto che questa vulnerabilità sia presente in praticamente tutte le versioni del plesk è da brivido, però credo che un minimo di responsabilità la si debba dara anche agli hoster che ancora oggi offrono soluzioni che sfruttano queste versioni. Non parlo solo di hosting italiani ma anche stranieri. Per nostra fortuna ogni giorno abbiamo una persona che ci tiene aggiornati i nostri tre server, però devo essere sincero... non prendetevela, ma secondo me la fate più pesante di quello che è in realtà. Basta aggiornare e stare aggiornati... E' vero che avere un server dedicato a noleggio o che altro di più avanzato non è come avere un hosting low cost, però dai... non è nemmeno così difficile da tenere aggiornato e quanto più sicuro. Se uno vuole bucare l'hosting low cost lo fa senza problemi, se vuole bucare un server lo fa... dovremo quindi stare lontani da internet? No dai...
  15. Devi seguire questi passi: prima di tutto apri Putty, se usi quello, ed alla richiesta della prima autenticazione dovrai usare l'username adminXXXXXX ed utilzizare la password che ti ha indicato Aruba una volta attivato il server. Fatto questo, essendo quella un'operazione che può eseguire solo un super user, dovrai inviare questi comandi: > su > inserisci password super user (che di default è la stessa che hai per l'utente adminXXXXXX > vi /etc/sysconfig/network sarà caricato l'editor con il contenuto del file network nella prima riga dovrasti avere HOSTNAME=xxxxxxxxxxxxxxx al posto di xxxxxxxxxxxxxxx dovresti indicare l'host di un dominio ospitato sul server, valido. Per modificare il testo, una volta dentro vi, per passare alla modalità insert dovrai premere il carattere i della tua tastiera. Una volta modificato, per uscire dalla modalità insert e passare alla modalità command puoi semplicemente premere Esc e per salvare il tutto, dopo aver premuto Esc, digita :x! (duepunti x punto esclamativo) e poi invio. Non obbligatorio ma consigliabile, dopo ogni modifica riavvia sempre il server. Tieni presente una cosa, questa è solo una delle tante modifiche che dovrai apportare... Altra cosa che devi fare sicuramente: chiudere tutte le porte che non sei sicurissimo di dover usare del server. Come si dice... sempre meglio chiuso che aperto :)
×