Jump to content

don_shine

Members
  • Content Count

    20
  • Joined

  • Last visited

  1. Grazie a tutti per le risposte:approved: Cercherò di rispondere facendo un sunto di tutto. In effetti le nuove offerte kimsufi prevedono un costo di setup, tranne che non si sottoscriva un contratto annuale ed io il mio setup già l'ho pagato un paio di mesi fa. In ogni caso mi hanno sostituito il disco e al momento sembra che fili tutto liscio. Mi sono accorto anch'io che l'assistenza è un po' fraccomoda, ma posso tollerarlo visto che sul server non ci faccio girare nulla di troppo importante. In ogni caso la sostituzione del disco ha richiesto, dallo scheduling all'intervento vero e proprio, circa 20 ore, con un preavviso di 15 minuti. Ma il top l'ho raggiunto quando ho dovuto aspettare due settimane per l'attivazione di un RPS con loro :stordita: Brutta esperienza quella di rebel, ma "chi va per questi mar questi pesci piglia", nel senso che credo ormai sia chiara a tutti la politica di OVH, vendono servizi unmanaged che più unmanaged non si può ed è questo che gli permette di avere costi così competitivi (a parte i grandi numeri). L'argomento base del thread rimane ancora in vigore: quali sono oggi, le alternative ad OVH? Hetzner mi sembra assolutamente valido in un'ottica di prezzo/offerta. Altre idee? Tutti gli altri grandi provider europei, da Leaseweb a 1&1, mi sembra abbiano prezzi ben più alti di OVH.
  2. @DonChisciotte Grazie per la segnalazione di Hetzner, i prezzi sono ottimi ma i server mi sembrano troppo potenti per l'uso che devo farne (un i7 con 8gb di ram sarebbe sprecato attualmente). Me la tengo buona per eventuali upgrade futuri. Da OVH comunque hanno deciso di provare a cambiarmi l'hard disk per "problemi sui western digital", quindi incrociamo le dita. @Mago di OZ Sinceramente no, ma sai come si dice: "a mali estremi estremi rimedi". Quando girava bene, il server che ho ora da OVH era assolutamente perfetto per le mie esigenze, ma se sono costretto a muovermi devo trovare l'alternativa migliore o la "meno peggiore". Considera che col calo di produttività che ho avuto è come se avessi un Commodore64 tra le mani, alro che core2 quad :asd:
  3. Buon pomeriggio a tutti e ben ritrovati. Si tratterà sicuramente di un argomento trito e ritrito, visti i prezzi concorrenziali di ovh/kimsufi, ma non sono riuscito a trovare nessuna discussione che potesse inerire le mie esigenze, o quantomeno sufficientemente aggiornata. Non ho nulla contro OVH, sono loro cliente da 8 mesi e mi sono sempre trovato più che bene. Ultimamente, però, ho seri problemi su un kimsufi di seconda fascia (Quad Core Q6600 2.40ghz 4gb ddr2 1TB hd), che ormai perdurano da circa 3 settimane. L'utilizzo che ne faccio è paragonabile a quello di un PC remoto, non devo hostarci nulla se non in casi di emergenza e utilizzo Ubuntu Desktop + NX per la connessione al desktop remoto. Fino a circa 3 settimane fa, appunto, il server andava che era una favola, dopodicché, all'improvviso, il buio. Non riesco minimamente a capire cosa sia successo, ma ha cominciato a bloccarsi di continuo. Top, ps aux e netstat tutti in ordine, le applicazioni si avviavano ma erano come in stand-by per poi aprirsi e funzionare tutte insieme dopo decine di minuti. Programmi che richiedevanoun tempo di esecuzione di <3s hanno cominciato a sfiorare picchi di 900s. Fin qui mi si potrebbe dire "chissà che hai combinato, hai incasinato il sistema", ma ho fatto numerose reinstallazioni del sistema operativo ed il server continuava a bloccarsi anche fresco di format. Ho provato anche a installarmi ubuntu server 9.10 e mettere ubuntu-desktop su quello, ma non è cambiato molto. L'assistenza mi ha detto che se avessi avuto il sospetto di un guasto hardware avrei dovuto bootare in rescue e fare i vari tests. Tests fatti e nulla fuori posto. Poi hanno provato a bootarmi da un kernel standard piuttosto che da quello custom OVH ma nisba. A questo punto vorrei che me lo sostituissero, ma non credo lo faranno, quindi sono propenso a muovermi altrove. Sistemi di tale potenza e su 100mbps, però, te li fanno pagare carissimi ed al momento non posso permettermelo. Sono capitato per caso su seaflow, perché di solito guardo all'estero, e sono rimasto piacevolmente colpito dai prezzi. La loro seconda macchina non è altrettanto potente, ma è su 100mbps metered a 3TB e sulla stessa fascia di prezzo, quindi potrebbe essere un'alternativa. So anche che seaflow segue questo forum, quindi magari potrei interfacciarmi direttamente con loro per ulteriori delucidazioni o eventuali customizzazioni. Nel frattempo, consigli? Ripeto i dettagli del sistema attualmente in mio possesso: Quad Core Q6600 2.40ghz 4gb ddr2 1TB hd - 100mbps fino a 3TB. Prezzo attuale: 48 euro iva compresa. Grazie per l'attenzione
  4. don_shine

    Posso virtualizzare o mi serve un altro server?

    Non faccio del bumping, volevo solo postare un aggiornamento. Per il momento ci ho semi-rinunciato. Ho tentato tutto quello che le mie esigue competenze mi permettevano ma nulla, mi ritrovo sempre con una VM debian che non può fare manco un apt-get o un ping. In locale, su windows, sono riuscito a venirne a capo e sto continuando a fare le mie prove qui, dopodicché, con qualche nozione in più sul networking ma soprattutto su linux ritornerò all'attacco sul server. Non voglio saltare a piè pari gli steps, è meglio capire a fondo il problema e cercare di risolverlo piuttosto che trovare soluzioni belle e pronte. Il blog, però, devo ancora pubblicarlo. Più che altro non vedo l'ora di capire "quanto tira", perché al momento è hostato su blogger e sto aspettando un dominio tutto mio prima di "spammarlo" a dovere. Vi ringrazio per la disponibilità e i consigli, ci riproveremo tra qualche tempo :approved:
  5. don_shine

    Posso virtualizzare o mi serve un altro server?

    Mai usato iptables e a questo punto veramente non so dove sbattere la testa. In linea teorica credo di aver fatto tutto quello che c'era da fare. So che molti potranno storcere il naso nel pensare che qualcuno con le mie non-competenze possa trovarsi ad amministrare un server, ma mi sembra un ottimo metodo per costringermi ad imparare. Pur non essendo riuscito a cavare un ragno dal buco almeno ho googlato il mondo intero cercando di venirne fuori e un paio di cosette nuove le ho assimilate. Credo che a questo punto mi resti solo da provare una re-installazione, magari con un kernel diverso o provando ad installare un altro OS sulla macchina virtuale. Ci sono altri file che potrei controllare nel frattempo? Altrimenti piallo tutto e riprovo daccapo, magari è stato solo un "typo" o un errore di distrazione (troppo ottimista, eh?").
  6. don_shine

    Posso virtualizzare o mi serve un altro server?

    Ecco che finalmente si smuove qualcosa, ho fatto un piccolo passo avanti. Avevo già fatto nell'host echo "net.ipv4.conf.vmnet1.proxy_arp=1" >> /etc/sysctl.conf && sysctl -p ma non era cambiato nulla, la VM continuava a non dare alcun cenno di vita all'esterno. Adesso, controllando che nel file /etc/sysctl.conf ci fosse la stringa net.ipv4.ip_forward = 1 come suggerito da Antonio, l'ho trovata e decommentata per renderla attiva. La VM, come prima, continua a non rispondere al browser, ma c'è stato un piccolo cambiamento. Mentre prima di quest'ultimo intervento pingando l'ip failover mi dava richiesta scaduta, se lo pingo adesso mi risponde il server host, dicendo "Host di destinazione irraggiungibile". Edit: Piccola aggiunta. Per quanto riguarda la questione "Bridge", avevo capito, pur non avendo nozioni di networking. In linea di massima mi era chiaro il perché non dovessi farlo e se ho insistito è solo perché, leggendo quel dummy0 sulla guida OVH, credevo di dover compiere un passo analogo anch'io. Ora che mi è stato spiegato che non è necessario e che, se ho ben capito, era solo un eccesso di zelo nella distro ovh per evitare connessioni accidentali, ma basta settare la rete della VM come host-only per non aver problemi, sono più sereno.
  7. don_shine

    Posso virtualizzare o mi serve un altro server?

    Ringrazio Rebel per avermi fatto notare il fatto del bridge, altrimenti non ci avrei pensato. Dunque, ecco cosa ho fatto finora: ho installato vmware, ma dal momento che mi ha dato una marea di problemi a causa del kernel ho reinstallato un kernel ubuntu prima di riuscire ad eseguire con successo vmware-config.pl Per quanto riguarda il bridge, ho fatto riferimento a OVH : VMware, ma lì si parla di un certo dummy0, che io non avevo. Durante l'installazione, quindi, il bridge di default è stato eth0. Arrivato al momento della creazione della VM, tramite l'interfaccia sul browser, gli ho allocato 5GB e 256mb di ram confidando nel fatto di poterla aumentare successivamente, se necessario. Installo Debian attraverso un cd "completo" (non essendo sicuro sulla questione network ho evitato il netinst) e faccio le prime sciocchezze, chiedendo l'installazione del webserver (apache=ok) e del database (postgresql=volevo mysql). In ogni caso l'installazione finisce, la VM fa il reboot e disinstallo postgresql. Poi, sul server host ho fatto, come da guida /sbin/route add <IP FAILOVER> dev vmnet1 la parte riguardante proxy arp l'ho saltata, quindi NON ho fatto: echo "net.ipv4.conf.vmnet1.proxy_arp=1" >> /etc/sysctl.conf && sysctl -p sulla VM guest mi si chiedeva di editare il file /etc/network/interfaces in questo modo: auto eth0 iface eth0 inet static address <IP FAILOVER> # indirizzo IP Failover per il server virtuale netmask 255.255.255.255 post-up /sbin/ip route add default dev eth0 Non avendo ben capito, mi sono limitato ad aprire il suddetto file con nano, cancellare tutto il contenuto e ricopiare il testo fornito da OVH. Ho fatto bene? dovevo aggiungerlo alla fine e lasciare intatto il contenuto iniziale? Non c'era alcuna linea simile a quelle fornite da ovh, quindi non avrei nemmeno saputo limitarmi ad editare. Tutto regolare? La mia VM ora usa host-only come da progreamma, ma mi chiedevo se fosse necessario cambiare ulteriormente parametri nella macchina host per far sì che il bridge punti non più a eth0 ma a quel certo dummy0 che non ho la più pallida idea di cosa sia.
  8. don_shine

    Posso virtualizzare o mi serve un altro server?

    Ed ecco che la "nubbiezza" viene a galla. Ho installato vmware sul pc di casa, montato l'iso di debian su una periferica virtuale e sto tentando di installare. Sono fermo alle impostazioni del network, proprio come mi aspettavo. Ho provato in automatico con DHCP, ma continua a darmi errore, ho provato ad impostare manualmente l'ip sia secondo il mio modem che secondo i network adapter di vmware, ma nulla. Arrivato al punto in cui dovrei connettermi a un mirror debian per apt continua a non trovarmi niente.
  9. don_shine

    Posso virtualizzare o mi serve un altro server?

    Ah, ok. Sapevo che vmware fosse gratuito in quanto lo scaricai qualche mese fa, ma navigando sul loro sito recentemente non riuscivo più a trovarlo e credevo avessero terminato l'offerta lasciando solo i prodotti a licenza. Allora faccio subito come hai consigliato e comincio a provare sul pc di casa. VMware server + debian e provo a caricarci un sito e renderlo accessibile dall'esterno. Se tutto va bene passo alle prove sul server, ma sono più che sicuro che avrò grossi problemi per configurare la rete. Purtroppo sul server non posso reinstallare l'OS per richiedere anche VMware, perché ho diversa giga parcheggiati lì, quindi sarò costretto a installazioni manuali. Vediamo un po'. Grazie per i chiarimenti
  10. don_shine

    Posso virtualizzare o mi serve un altro server?

    Grazie per la correzione al layout e per la risposta, Ste. Sono consapevole che un hosting condiviso mi solleverebbe da un bel po' di grane, ma non avendo dati precisi sulle macchine e sulla quantità di siti hostati, mi trovo un po' spaesato nello scegliere un'offerta. Parlano tutti di spazio disco, che è l'unica cosa di cui non mi interessa un granché ed avendo già avuto con ovh sia un server privato che un dedicato, ho dato uno sguardo alle loro offerta prima delle altre. Il problema con vmware è la licenza, che vorrei evitare almeno per il momento. Perché il server in mio possesso non è adatto alla virtualizzazione? L'IP è ancora un enorme mistero, mi sa che lo capirò meglio solo quando farò le prove pratiche. In fin dei conti, se per la virtualizzazione mi è indispensabile una soluzione commerciale (con i suoi relativi costi) e rischio di trovarmi comunque un "hosting" che sia al passo se non peggio di uno condiviso allora tanto vale cacciare qualche ulteriore euro e provare lo shared, mantenendo il dedicato che già ho per prove varie. Ma visto che i 100mbps ci sono, la ram e le risorse mi bastano sia per giocare che per hostare, avrei voluto far coincidere le due cose e ottimizzare l'investimento.
  11. Salve a tutti, premetto che non ero sicuro che fosse questa la sezione adatta in cui postare, dal momento che essendo un principiante mi trovo più a mio agio spaziando su diversi argomenti che dovendo seguire un unico "thread" (per questo vogliano i moderatori scusarmi nel caso stia arrecando disturbo). Probabilmente nessuno ricorderà "la mia storia", ma vi faccio un breve sunto utile alle domande che farò in seguito. Qualche mese fa ho preso un kimsufi, per "i miei loschi affari" (100mbps fan sempre comodo) e per fare qualche prova. Dal momento che lo scopo primario non era quello di installarci un webserver, ma di usarlo principalmente come computer a distanza, optai per l'installazione di ubuntu desktop. Nel frattempo però non ho mai abbandonato la linea di comando e ci ho anche fatto qualche esperimento per un sito (il cassico, ormai inflazionato, blog Wordpress), che vorrei pubblicare tra poco. Non avendo, però, le physique du role per improvvisarmi amministratore a tutti gli effetti, pensavo di rivolgermi ad un hosting condiviso, ma le offerte "economiche" non facevano al caso mio (ho letto che wordpress è un bel mattoncino e il blog dovrebbe partire con circa 500 giornalieri, che ho intenzione di portare ad almeno 3000 in un lasso di tempo ragionevole) e poi, in fin dei conti, un server già ce l'ho, perché pagare ulteriormente? Per far in modo, quindi, che "i miei loschi traffici" non interferiscano con la vita del sito avevo pensato ad una soluzione di virtualizzazione in modo da garantire una certa quantità di risorse al sito e guadagnarne anche in sicurezza, dal momento che i miei dati sarebbero in un computer virtualmente differente da quello che ospita il sito. Sarei intenzionato a partire con un ubuntu server 9.04 più il classico LAMP (forse lighttpd potrebbe rivelarsi migliore per la gestione dei PHP, ma su Apache c'è molto più materiale in rete). Di spazio disco me ne serve ben poco, con un giga ci starei già più che largo, ma il primo dubbio ce l'ho sulla quantità di ram da dedicare. Il server che ho al momento è il primo della gamma kimsufi (un Intel Celeron 1.20ghz con 2gb di ram), 512mb possono bastare per la macchina virtuale? Non avendo intenzione alcuna di pagare licenze varie, posso utilizzare VirtualBox? Altro grosso dubbio riguarda l'IP, perché non so come ci si comporti in questo modo. Nell'offerta ho un solo indirizzo IP più un failover (che sto già usando sul sito di prova). Questo IP failover a che serve, in parole povere? Potrei usarlo sulla macchina virtuale o devo comprare un altro IP da ovh (un IP già mi serve per il resto delle mie attività e vorrei che le due cose risultassero separate)? Sono certo di avere anche altre domande, ma al momento non mi sovviene null'altro. Ringrazio per l'attenzione e colgo l'occasione per complimentarmi con l'utenza tutta per le competenze dimostrate, ma in particolar modo con i provider, che pur avendo chiari interessi commerciali non disdegnano di dar supporto e aiuto anche a chi è cliente di altri provider (come me, nella fattispecie):approved:
  12. Per il poco che faccio non è uno spreco, spendo 35euro ma ne ricavo di più. Grazie per il traceroute, provo subito. Credevo ci fosse bisogno di effettuarlo durante una connessione dati.
  13. Altri test con rapidshare: nessun problema e solite velocità verso TeliaSonera, velocità ridicole verso Level3 e globalCrossing
  14. Disclaimer: sono un incapace. Sera a tutti, sono un felice possessore di un kimsufi, che utilizzo da ormai un mese e mezzo alla stregua di un PC (nel senso che ci ho installato ubuntu desktop e ci navigo, ci giochicchio, sperimento sia via desktop che via ssh). Da questa mattina ho notato una nettissima diminuizione della velocità di upload che, mentre nei giorni passati sopportava tranquillamente picchi di 50+mbps, è diminuita, oggi, fino a 150KB/s, senza mai superare 1mbps. Essendo io, come ho specificato nel disclaimer, un n00b e non avendo a disposizione altri server per effettuare qualche test, mi sono affidato a tutti i siti di filehosting che conosco (Rapidshare, Hotfile, Netload, Depositfile, Filefactory), tentando sia trasferimenti via HTTP che via FTP, ma i risultati sono stati i medesimi. Ho chiamato l'assistenza OVH, la quale dice di non notare alcun problema di rete sulla mia macchina e mi consiglia di effettuare un traceroute e inviarglielo, per autorizzare, eventualmente, ulteriori accertamenti/interventi. Purtroppo, però, non ho la più pallida idea di cosa sia un traceroute, di come effettuarlo e se posso utilizzare rapidshare e company per farlo o ho bisogno di un altro dedicato. Se qualcuno potesse aiutarmi gliene sarei molto riconoscente. Grazie
  15. Grazie per la risposta, Andrea, temevo che la lunghezza del mio intervento scoraggiasse ogni possibile replica. Innanzitutto grazie per la risorsa che mi hai segnalato, ho già aggiunto ai bookmarks e vedrò di approfondirla al meglio. Ho già fatto un esperimento con putty per provare ad installarmi quello script che avevo trovato sul forum debian. Mi sono armato di una guida trovata online sull'installazione di ffmpeg (richiesto dallo script) e ho cominciato a fare le mie prove a suon di wget, tar, ./configure, make e make install. Mi sentivo soddisfatto del fatto di essere in grado, quantomeno, di seguire una guida, ma al primo intoppo (le librerie OGG che non si trovavano e tra l'altro manco mi servivano), naturalmente, non avevo la più pallida idea di dove sbattere la testa, e via con google per trovare una soluzione. ffmpeg suppongo di averlo installato, ma ora non ho idea di come installare il programma vero e proprio (quello che dovrebbe generarmi le anteprime). Abituato ormai alla procedura standard del ./configure && make && make install, credevo di dover fare lo stesso, ma non sono stato sufficientemente fortunato. Linux è arabo per me, mi pento di non aver mai tentato un approccio prima d'ora. Oltre che nei comandi, sto trovando un'enorme difficoltà a capire la struttura delle directory, la differenza tra root e home e il senso di tutti quei src e bin. Al momento non ho fatto ancora guai, quando mi arriverà da parte di ovh la richiesta di rimborso per avergli fuso il server vi farò sapere.
×