Jump to content

fjstudio

Members
  • Content Count

    29
  • Joined

  • Last visited

  1. Ciao, Il motivo, come accennato all'inizio del post, era di avere PHP su Windows per via di ms sqlserver. Il driver nativo microsoft per mssql server da cio che ho letto è disponibile solo per windows. (so che ci sono driver alternativi per mssql server su linux) F.
  2. Ciao, Di recente ho attivato un nuovo server dedicato con a bordo windows 2012 Plesk 11.5.30 (obbligato perchè ci doveva essere ms sqlserver) Ho altri server, la maggior parte con Plesk 11.x per Linux. In linux all'interno della {WEBSPACEROOT} e.g. /var/www/vhosts/domain-name, ho a disposizione una cartella "private", rw da php; Qua ad esempio posso inserire file di php ecc con credenziali o classi, non raggiungibili da http; e.g. zendframework per esempio. Ho creato questa cartella dal pannello Plesk, e con mia sorpresa mi sono reso conto che non è possibile dare privilegi al Plesk Domain user per questa cartella. (ovviamente è in open_basedir) Certo potrei intervenire da Windows, ma questa strada secondo me sarebbe errata, in quanto dovrei trovare una soluzione che sia compatibile con l'architettura di Plesk (per una miriadi di motivi) Qualcun altro si è già scontrato con questa problematica ? Qualcuno sa se in Plesk 12 è stata evoluta la struttura del vhosts (piu orientata a quella linux) Ho trovato un tutorial, con una soluzione che non ritengo valida (Installing Zend Framework 2 on Plesk 12), veramente brutta secondo me. Ciao F.
  3. Dopo 5 ore sono riuscito a parlare con l'assistenza dedicati (commerciale) non sono riuscito a farmi dire quale sia il problema ....
  4. La posta è di nuovo completamente giù..... è vergognoso che non rispondano al telefono, ne pubblicchino niente ......
  5. Hai ragione quella è l'ora dell'ultimo riavvio, infatti dopo poco ritornò raggiungibile
  6. L'ora dello stacco a quanto risulta dal log di uno dei miei server è alle 11.53 (il 29/04 fu alle 11.55) Comunque c'e' un up parziale .... soprattutto ci sono diversi server di posta ancora down ho verificato con un ping diversi pop3 che sono completamente morti
  7. Confermo tutto up dalle 14 circa in poi ..... nessuna notizia ne su assistenza.aruba, ne su twitter; telefoni ancora giù... Ho notato che su assistenza.aruba il 6 luglio hanno fatto un aggiornamento dei loro sistemi ..... magari è stato quello il guaio. Rimane il fatto però che al telefono sull'assistenza dedicati non risponde nessuno
  8. qui scusa: Problemi server Aruba down, siti offline
  9. Lo so che il centralino è voip ma se dai assistenza sui dedicati 24/7/365 ti attrezzi con linee normali e qualche cellulare .... io all'anno gli do un sacco di soldi....... Comunque si vocifera su qualche blog di uno stacco preventivo per gli attacchi alla rete di questi giorni
  10. Confermo dalle 11.45 è tutto down ..... Quello che non è accettabile, è che non rispondano al telefono .... io ho diversi serverdedicati, e pretendo che la gente mi risponda almeno al telefono.... i miei clienti a questo giro sono molto arrabbiati... possibile che in 45 minuti di down nemmeno un a news su twitter ?
  11. fjstudio

    ssl con plesk (9.3)

    Ciao, Sono riuscito a far andare il tutto. Il file responsabile di quest'ultima anomalia è /etc/conf.d/*psa_httpd.conf Quà succedono cose davvero strane. Vi è una direttiva che richiama il certificato di default. Se la si decommenta sperando che vengano interpetati i valori del file di conf del dominio httpd.include, apache non riparte. L'unico modo che ho trovato per far quadrare il tutto è intervenire appunto nel file psa_httpd.conf all'interno del tag <VirualHost IP:443> specificando qua i valori SSLCerificateFile e SSLCACertificate file. Coì funziona. Per fare le cose fatte bene però e completare il tutto è da capire se le configurazioni di default in ssl.conf per il default virtualhost possono essere scritte anche nel file vhost_ssl.conf oppure se vannno scritte in psa_httpd.conf. L'unica è andare per tentativi. In ogni caso plesk sotto l'aspetto della gestione ssl è fatto male secondo me. Grazie per il vostro aiuto alla prossima. Ciao
  12. fjstudio

    ssl con plesk (9.3)

    Ciao, Avrei fatto qualche passo in avanti, adesso credo che manchi solo un'ultima cosa ma non riesco ad arrivarci. (per chi legge solo questo post ricordo che sono centos5.4 plesk9.3 e cho ho ip dedicato per il dominio ssl) Ho risolto il problema della generazione dei certificati facendo le seguenti operazioni: Dal pannello plesk sotto il dominio vado su aggiungi certificato. Poi compilo i campi correttamente e clicco su request. Mi viene generata le server.key non passwordata e la parte csr. Poi dal server attraverso openssl creo la chiave ca.key e il certificato ca.crt Attraverso l'utility sign.sh (non facile da trovare e configurare) sono poi riuscito a firmare il certificato server server.crt Torno sul pannello di controllo plesk ed aggiugo il certificato server firmato server.crt e il certificato ca ca.crt Plesk lo digerisce senza problemi adesso ho tutto il set di certificati corretti (da cui poi mi posso generari i miei cert client .pfx e .p12 Riconfiguro il vhost con websrvmng stoppo e restarto apache provo ad andare su https://www.mydomain.com ma il certificato mostrato dal browser è sempre quello di default A questo punto cerco ancora info e dopo un po trovo questa interessante kb KB Parallels: I receive a wrong certificate when I open any domain via HTTPS. I added the certificate under server settings, assigned this certificate to an IP, set default domain for the IP and restarted Apache. But if I open https://domain.tld I st dove dicono di intervenire in /etc/conf.d/ssl.conf e di togliere tutto quello che sta tra <VirtualHost _default_:443> e il suo relativo tag di chiusura Faccio un backup di tutti i file di conf e poi applico la modifica. Stoppo restarto apache. Provo ad andare di nuovo su https://www.mydomain.com ma ancora vedo il certificato di default Dato che adessol in ssl.conf non ci sono più i riferimenti ai certificati di default localhost.crt, localhost.key non riesco a comprendere da quali file possa prendere queste impostazioni, salvo che ci sia un qualche sistema di cache il quale richiede il riavvio della macchina. Qualche suggerimento in merito ? Credo che risolvendo questo particolare poi debba andare per forza. Ogni suggerimento è gradito Ciao
  13. fjstudio

    ssl con plesk (9.3)

    Ciao, Presumo che siano validi dai controlli tornano. Li ho creati seguendo questo tutorials Van's Apache SSL/TLS mini-HOWTO (ho ripreso solo la parte dei certificati adattandolo alla mia situazione) L'unica cosa che mi rimane da provare è di firmarli con l'utility sign.sh per la quuale mi sono documentato ieri. Anche se a livello di dialogo client/server per adesso questo non può essere il problema; Sembra che non ci sia modo di importare un certificato completo da plesk a meno di non partire dalla privatekey e crt generati da plesk (ma seguendo questa strada poi come mi posso generare gli altri ?) Grazie per la risposta Ciao
×