Jump to content

Search the Community

Showing results for tags 'andata'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Richiesta informazioni e consigli hosting
    • Domini e Registrazioni
    • Shared e Managed Webhosting
    • WebHosting - Primi passi
    • Server dedicati, colocation, connettività e scelta data center
    • VPS - Virtual Private Server
    • Cloud Computing e Cloud Hosting
    • Gestione Server Windows e Server Linux
    • E-mail e Managed Services
    • Pannelli di controllo e Hosting software
    • Professione Hosting Provider
  • Sviluppo Web e Tempo Libero
    • Io Programmo
    • Promozione, advertising e SEO
    • Off-Topic
    • Il tuo sito
  • Guide su hosting, domini, server, CMS e Cloud Computing
    • Articoli e Guide su hosting, domini e cloud computing
    • Annunci e News
    • Offerte Hosting - Provider HostingTalk.it

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografia


Località


Interessi


Cosa fai nella vita?


Il tuo Hosting Provider?

Found 1 result

  1. Ciao a tutti, vi vorrei portare la mia esperienza per quello che riguarda la co-location presso Aruba Premetto che tutto quello che scrivo qui e' vero e verificabile, privatamente, da parte di chi volesse controllare, in quanto oltre il 95% dei problemi sono stati salvati nel trouble ticketing system di aruba (assistenza.aruba.it) Ovviamente, per motivi di riservatezza e copyright, non posso pubblicare letteralmente le e-mail di risposta da parte dello staff di Aruba ma provvedero' a riferirle usando mie parole Tutto inizia due anni fa, ottobre 2005, quando un mio cliente (una piccola impresa di corsi di informatica che lavora con la regione lombardia) mi chiede di co-locare, a basso costo, una macchina per gestire un software di e-learning usato intensivamente Dopo alcune valutazioni, la scelta ricade su un Mac mini G4 1.42 GHz con Mac OS X Server 10.4 Dopo un discreto giro sul web, concludo che il servizio piu' economico in Italia e' l'housing di aruba, offerto ai tempi al prezzo di 15 Euro + iva al mese per uno spazio tower con 5+1 mbit/s di banda e 25 GB di traffico mensile Si procede quindi all'attivazione del servizio e a portare fisicamente il server presso la struttura il 31 ottobre 2005 Dopo pochi giorni iniziano i primi problemi: quando il traffico da un singolo IP diventa pesante, la macchina si assenta da Internet per qualche minuto per poi ricomparire A seguito di una banale verifica con il comando uptime, concludo che sicuramente la macchina e' rimasta accesa nel frattempo e dopo ulteriori decine di verifiche, sono certo che si tratta di un problema di connettivita' di aruba ma per ora lascio correre (piu' sotto scoprirete com'e' andata) Intorno al 20 novembre 2005, aruba dirama un comunicato avvisando i clienti che il 26 sera alle 23.30 provvedera' al cambio degli ups e quindi invita tutti i clienti a spegnere le macchine, in quanto poi i loro tecnici provvederanno a riaccenderle dopo un tempo non precisato (!) A parte il fatto che l'ora in cui eseguire questa operazione e' sicuramente sbagliata (queste cose si fanno alle 3-4 del mattino, quando il traffico in base ai grafici del mix e' al minimo, non quando mezza Italia e' ancora sveglia) e che non e' stato garantito un tempo di ritorno online dell'infrastruttura (ci vollero infatti varie ore perche' il server tornasse up, per fortuna che non era un server critico), quello che e' successo e' stato ben peggiore delle premesse Per accelerare le procedure di spegnimento dei server, aruba ha pensato che l'idea migliore fosse quella di togliere direttamente la corrente alle 23.30 circa che, unito al fatto che a causa di uno dei soliti problemi di connettivita' non sono riuscito a loggarmi in ssh in tempo utile per spegnere la macchina, ha fatto si che la macchina godesse di uno shutdown brutale, con gioia del db server e del filesystem, che dovetti ripristinare remotamente con qualche danno, in quanto ovviamente la cache di mysql non viene flushata completamente se non allo spegnimento o su comando esplicito Nel frattempo i problemi di connettivita' persistono e in data 27/11 il server e' di nuovo irraggiugibile, motivo per il quale decido di aprire un ticket, al quale mi viene risposto che da loro il server e' pingabile (risposta decisamente poco utile, in quanto se il problema fosse stato per caso nel routing verso l'esterno loro non avrebbero potuto accorgersene, visto che le macchine di supporto sono nella stessa LAN) In data 3 gennaio 2006 succede la catastrofe: apro un ulteriore ticket per segnalare che il server non e' raggiungibile e chiedo di verificare se il led sul frontale e' acceso, dopo 30 minuti effettuo una variazione del ticket indicando che la macchina e' tornata ad essere raggiungibile (leggi anche come: cessate il fuoco) e alle 11.37 arriva la loro terribile risposta: "gentile cliente, come da sua richiesta abbiamo riavviato il server" Voi avete letto nelle righe sopra una richiesta di riavvio del server? Neanche io :icon_dho: Risultato? Il solito db mysql che ha perso pezzi qua e la, non recuperabili, oltre a un filesystem che ormai ha bisogno di esercizi di fisioterapia Ovviamente i problemi di connessione proseguono ancora e sono costretto ad aprire l'ennesimo ticket in data 9 marzo 2006, inviando una lista dettagliata dei downtime verificatisi negli ultimi 6 mesi e dopo un mio sollecito a rispondere, ricevo la notizia che il mio server e' di nuovo raggiungibile da Internet ma il motivo per cui prima non lo fosse non mi viene comunicato Parlando di supporto, bisogna precisare che aruba promette si una risposta entro 15 minuti, la verita' e' che spesso sono stato costretto a inviare solleciti su solleciti nella pagina del ticket, per avere una risposta magari anche un giorno dopo Finalmente, in data 8 maggio 2006 (7 mesi dopo l'inizio della colocation), dopo aver inviato di nuovo una lista dei piu' recenti downtime (riportata subito alla fine di questo paragrafo) e grazie anche alla segnalazione congiunta da parte di un mio amico, anche lui cliente di aruba, riusciamo ad ottenere che Aruba investighi il problema, confermando quello che sospettavo da 7 mesi: lo switch a cui siamo (io e il mio amico, per fortuna mia e sfortuna sua) collegati e' rotto da mesi e perde la connessione ogni tanto Il grande giorno e' arrivato! Finiscono i downtime che avevano rovinato le notti a me e al mio cliente (immaginate la sua rabbia quando durante un test in aula i suoi clienti vedevano scomparire nel nulla le 100 risposte che avevano dato, per il fatto che il server era in down e il browser andava giustamente in timeout, costringendoli a ripartire da zero) Ecco la lista dei downtime che avevo inviato ad aruba (tengo a precisa che questo e' solo un piccolissimo estratto del log del mio servizio di monitoring) 2006-05-08 07:23:03 : back_up 2006-05-08 07:06:19 : down 2006-05-08 05:22:29 : back_up 2006-05-08 03:58:12 : down 2006-05-08 03:42:58 : back_up 2006-05-08 03:33:18 : down 2006-05-07 05:46:28 : back_up 2006-05-07 05:38:25 : down 2006-05-06 22:23:47 : back_up 2006-05-06 21:22:17 : down 2006-05-05 20:14:10 : back_up 2006-05-05 19:57:30 : down 2006-05-03 01:41:12 : back_up 2006-05-03 01:19:24 : down 2006-05-03 00:39:42 : back_up 2006-05-03 00:18:44 : down 2006-05-02 13:12:22 : back_up 2006-05-02 12:43:10 : down Da mesi sembrava che la connettivita' fosse tornata stabile (o meglio, fosse FINALMENTE come il mio cliente si aspettava da contratto) quando in data 23 agosto 2007 devo, di nuovo, aprire un altro ticket: Signore e signori, la rete di nuovo ha lo stesso problema del 2005-2006 Invio ad aruba un'altra interminabile lista di downtime ma non ottengo una risposta tecnica utile All'interno dello stesso ticket, il giorno immediatamente successivo, posto una richiesta di aiuto, indicando che la macchina in questo preciso momento e' di nuovo scomparsa dalla rete e allego un traceroute dalla mia fibra fastweb verso il Mac mini presso aruba, in cui si vede come superato un certo hop i pacchetti vanno tutti in drop Mac:~ cariafraweb$ traceroute 62.149.198.162 traceroute to 62.149.198.162 (62.149.198.162), 64 hops max, 40 byte packets 1 192.168.1.1 (192.168.1.1) 2.149 ms 1.007 ms 1.921 ms 2 1.60.64.3 (1.60.64.3) 2.152 ms 2.448 ms 2.219 ms 3 10.251.112.89 (10.251.112.89) 2.256 ms 2.222 ms 2.208 ms 4 10.251.108.26 (10.251.108.26) 2.252 ms 3.230 ms 2.469 ms 5 10.251.109.1 (10.251.109.1) 2.507 ms 3.775 ms 2.367 ms 6 10.251.113.194 (10.251.113.194) 2.334 ms 2.848 ms 2.408 ms 7 10.52.1.245 (10.52.1.245) 2.654 ms 2.589 ms 2.578 ms 8 10.0.0.149 (10.0.0.149) 2.596 ms 2.791 ms 2.651 ms 9 10.254.0.89 (10.254.0.89) 2.855 ms 2.916 ms 2.714 ms 10 10.254.0.13 (10.254.0.13) 2.865 ms 3.254 ms 2.732 ms 11 89.96.200.154 (89.96.200.154) 3.154 ms 3.131 ms 3.582 ms 12 26.26.26.18 (26.26.26.18) 9.527 ms 11.122 ms 11.382 ms 13 26.26.26.161 (26.26.26.161) 12.315 ms 4.203 ms 7.746 ms 14 26.26.26.137 (26.26.26.137) 8.496 ms 4.235 ms 7.677 ms 15 89.97.200.253 (89.97.200.253) 17.932 ms 17.362 ms 39.361 ms 16 89.97.200.69 (89.97.200.69) 13.437 ms 17.131 ms 13.500 ms 17 83-103-100-38.ip.fastwebnet.it (83.103.100.38) 16.983 ms 13.792 ms 17.479 ms 18 151.6.3.165 (151.6.3.165) 14.063 ms 15.169 ms 17.821 ms 19 151.6.7.33 (151.6.7.33) 14.037 ms 17.925 ms 18.818 ms 20 151.6.64.229 (151.6.64.229) 23.434 ms 23.162 ms 21.293 ms 21 151.6.64.10 (151.6.64.10) 21.417 ms 23.087 ms 20.777 ms 22 7606P1.aruba.it (62.149.128.29) 22.621 ms 22.180 ms 21.531 ms 23 * * * 24 * * * 25 * * * 26 * * * 27 * * * 28 * * * 29 * * * 30 * * * 31 * * * 32 * * * 33 * * * 34 * * * 35 * * * 36 * * * 37 * * * 38 * * * 39 * * * ^C Mac:~ cariafraweb$ Dopo 30 minuti ancora nessuna risposta, inserisco allora un sollecito e sono costretto a inserine un altro alle 21.00, 57 minuti dopo il mio primo post di richiesta aiuto Finalmente arriva una risposta alle 21.14, dicendomi che ritengono che il server sia spento, visto che il monitor non da segnale (il motivo e' molto semplice: dopo 10 minuti ho messo che l'output video venga interrotto, questo e' normalissimo e anzi di default su credo ogni sistema server), richiedo allora che colleghino un mouse e lo muovano per "svegliare" l'uscita video Mi rispondono che secondo loro la macchina e' proprio ferma e la riavviano (anche questa volta senza chiedermi il permesso per farlo) Appena riesco ad entrare in ssh scopro, ovviamente, quello che pensavo: la macchina era rimasta assolutamente viva, visto che ha continuato a popolare i log fino a pochi secondi prima del riavvio, quindi non solo era il solito problema di connettivita' di aruba ma si aggiunge il fatto che il tecnico non aveva collegato correttamente tastiera e mouse... In data 7 settembre 2007 faccio un'ulteriore scoperta: parte dei downtime sono anche dovuti al fatto che il loro dns primario (al quale e' affidata la gestione del dominio del mio cliente) spesso va giu' La diagnostica di opendns cache check, effettuata da me alle ore 13.11 dello stesso giorno, e' piuttosto chiara: Nameserver trace for test.francescocariati.net: * Looking for who is responsible for root zone and followed h.root-servers.net. * Looking for who is responsible for net and followed e.gtld-servers.net. * Looking for who is responsible for francescocariati.net and followed dns2.technorail.com. Nameservers for test.francescocariati.net: * dns.technorail.com returned (SERVFAIL) * dns2.technorail.com Il motivo per il quale il dns secondario non abbia svolto il suo lavoro mi rimane oscuro Chiedo spiegazione di questo ennesimo problema e, dopo 2 solleciti, ottengono risposta dopo un GIORNO :help: Alla lista dei problemi che ho elencato in questo enorme post, possiamo aggiungere tutte le varie telefonate al loro numero di supporto notturno per chiedere di controllare che fine avesse fatto la mia macchina Aggiungiamo che verso maggio arriva una sorpresa inattesa: il contratto del mio cliente e' stato, unilateralmente, automaticamente aggiornato a quello nuovo, chiedendo quindi un supplemento di 72 Euro ivati per il rinnovo annuale (prima costava 15 + iva al mese, adesso 20 + iva al mese, quindi per un ipotetico rinnovo annuale la differenza e' di 60 euro piu' iva) Loro giustificano questa modifica con il fatto che adesso abbiamo a disposizione 100 Mbit/s di cui, pero', il mio cliente non ne sentiva la mancanza, mentre avrebbe gradito tenersi 60 euro in tasca Per concludere, alla luce di quanto sopra esposto, non me la sento proprio di consigliare il servizio di co-location di aruba a una persona fisica o giuridica che necessita di un servizio un minimo affidabile Ho gia' provveduto a richiedere i moduli per la rimozione del server dal loro datacenter, per poi rilocarlo a brevissimo presso un altra server farm (non mi sembra giusto scriverla chiaramente qui, qualcuno potrebbe pensare che sono venuto per fare pubblicita' ), in quanto i danni subiti dal mio cliente in 2 anni sono quantificabili in migliaia di Euro Per ulteriori domande sono qui Ciao
×