Vai al contenuto
epiworld

Indirizzo senza www non funziona!

Recommended Posts

Salve!

 

Ho trasferito recentemente "www.miodominio.it" su TopHost.

 

Tutto bene se nella barra degli indirizzi digito "www.miodominio.it", ma i problemi nascono se scrivo l'indirizzo senza il www.

 

TopHost dice che la funzione non è supportata (evvvvabè.... a saperlo prima...), ma, purtroppo, con le ricerche di google compaiono spesso pagine che fanno riferimento all'indirizzo senza www e il navigatore non può più accedere al mio sito, se non ridigitando l'indirizzo.

 

Tenete presente che in realtà il sito è su un hosting americano con un dominio .org e che quindi viene eseguito una redirezione tramite CNAME da tophost al sito .org.

 

C'è qualche possibilità di risolvere il problema senza TopHost?

 

C'è qualche maintainer che consente di usare o meno il www senza tanti problemi a prezzi simili a quelli di TopHost?

 

Grazie

Ciao

Share this post


Link to post
Share on other sites

Se tophost non ti permette di modificare il record dns e di creare la corretta configurazione di apache per consentirne l'utilizzo senza www, credo proprio non ci sia soluzione, perchè quando l'utente arriva sul server di tophost tramite "dominio.xxx", il server non saprebbe come gestire tale richiesta.

 

Credo che qualunque hoster (a quanto pare tranne tophost e forse aruba) con gestione dns dovrebbe permettere la visualizzazione del sito senza il www.

Share this post


Link to post
Share on other sites

Grazie TheDarkITA!

In effetti mi è sfuggita la FAQ: sarò più attento in futuro.

Ora fiunziona!

Ma il supporto questa volta ha evidentemente toppato (termine giusto per l'occasione ;) )

 

-----------------------------------------------------------

Risposta del tecnico del Supporto di Primo Livello:

Gentile xxxxxx, la ringraziamo per averci contattato.

 

Al momento non è possibile utilizzare con tophost domini senza il prefisso www.

 

Le auguriamo buona giornata.

-----------------------------------------------------------

 

Grazie a tutti.

Ciao

:)

Share this post


Link to post
Share on other sites

In effetti l'uso del record @ in Tophost comportava dei problemi di cui parlavano nella faq:

www.tophost.it/aiuto/cat2/11/199/

 

Cito da quella faq:

"ATTENZIONE: è possibile inserire il record @ SOLO nel caso in cui tutti i servizi vengono puntati sul server esterno. Se si vuole lasciare la posta sui nostri server, il record DNS @ NON deve essere inserito, altrimenti ci sarannno anomalie nello smistamento delle email."

 

Pensandoci bene, non saprei spiegare perche' cio' dovrebbe influire sul server di posta; probabilmente qualche cavillo nella configurazione di Tophost, oppure mi sfugge qualcosa :)

Share this post


Link to post
Share on other sites

Crea un account o accedi per lasciare un commento

Devi essere un utente registrato per poter lasciare un commento

Crea un account

Iscriviti per un nuovo account nella nostra comunità. È facile!

Registra un nuovo account

Accedi Subito

Sei già registrato? Accedi da qui.

Accedi Adesso

×