Jump to content
Sign in to follow this  
pchs

Aggiungere alias nel file interfaces

Recommended Posts

Salve a tutti,

 

ultimamente sono stato informato dal mio MNT che il cambio DNS non è potuto avvenire a causa di un mancato settaggio dell'ip secondario.

 

Praticamente da DA ho configurato tutto bene, ma l'assistenza del mio vps (seflow) mi ha suggerito di aggiungere l'ip secondario come alias nel file interfaces.

 

In pratica però non so come si aggiunga, o per meglio dire non so l'istruzione da aggiungere al file per fare ciò.

 

Chi sarebbe cosi gentile da dirmi o linkarmi una risorsa che mi spieghi come fare?

 

Grazie.

Share this post


Link to post
Share on other sites

Ciao Matteo,

 

anche stamane ho provato a pingare l'ip secondario, eppure non va. La configurazione da DA va bene, il file interfaces l'ho modificato per filo e per segno come hai detto tu, ora come mai non va?

 

Grazie

Share this post


Link to post
Share on other sites

Ecco qua il risultato di ifconfig -a

 

vps:~# ifconfig -a
dummy0    Link encap:Ethernet  HWaddr CA:4D:81:84:84:25
         BROADCAST NOARP  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth0      Link encap:Ethernet  HWaddr AA:00:00:5D:5A:1A
         inet addr:194.177.98.211  Bcast:194.177.98.255  Mask:255.255.255.0
         inet6 addr: fe80::a800:ff:fe5d:5a1a/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:647004 errors:0 dropped:0 overruns:0 frame:0
         TX packets:528003 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:74827557 (71.3 MiB)  TX bytes:645445195 (615.5 MiB)

eth0:0    Link encap:Ethernet  HWaddr AA:00:00:5D:5A:1A
         inet addr:194.177.98.212  Bcast:194.177.98.255  Mask:255.255.255.0
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

gre0      Link encap:UNSPEC  HWaddr 00-00-00-00-FF-00-00-00-00-00-00-00-00-00-00-00
         NOARP  MTU:1476  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

ip6tnl0   Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
         NOARP  MTU:1460  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:146362 errors:0 dropped:0 overruns:0 frame:0
         TX packets:146362 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:117344369 (111.9 MiB)  TX bytes:117344369 (111.9 MiB)

sit0      Link encap:IPv6-in-IPv4
         NOARP  MTU:1480  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

tunl0     Link encap:IPIP Tunnel  HWaddr
         NOARP  MTU:1480  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Share this post


Link to post
Share on other sites

Guarda, la configurazione dovrebbe essere giusta (sia per quanto riguarda cosa hai aggiunto ad /etc/network/interfaces che il risultato di ifconfig -a).

 

Non so se il tuo provider applica dei filtri sugli ICMP in entrata/uscita verso/dagli IP secondari assegnati al VPS, perché effettivamente il primo IP riesco a pingarlo mentre il secondo no.

 

Su quello aggiuntivo però sono aperte, tra le altre, le porte 80/tcp e 2222/tcp (rispettivamente apache e directadmin) quindi penso sia OK. ;)

Share this post


Link to post
Share on other sites

Se applica filtri o meno lo dobbiamo chiedere a SeFlow :) In ogni caso, spero che questa volta il NIC effettui una volta per tutte il cambio MNT e aggiorni questi maledetti DNS :)

 

Grazie per i consigli. ;)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×