Jump to content
Sign in to follow this  
satifal

plesk e vhost.conf

Recommended Posts

Salve a tutti, avrei un problema, possiedo un VPS su aruba con SO Linux e pannello plesk. Su uno dei domini ospitati ho necessità di utilizzare una libreria PEAR per utilizzare la crittografia RSA. Ho modificato la vove "include_path" nel file php.ini affinchè includesse il percorso nel quale si trova tale libreria, ma quando richiamo una sua funzione ricevo un messaggio di errore in quanto il file richiamato non si trova in un percorso consentito "open_basedir". A questo punto volevo modificare le impostazioni di tale attributo ed ho notato che esso viene impostato da plesk nel file var/www/vhost/dominio.com/conf/httpd.include. Non è possibile modificare tale file in quanto esso è gestito direttamente da plesk, ma è necessario inserire le modifiche nel file var/www/vhost/dominio.com/conf/vhost.conf e successivamente lanciare il comando /usr/local/psa/admin/sbin/websrvmng -a -v affinche tali modifiche vengano rese attive. Purtroppo nonostante tale procedura quando controllo le modifiche mediante il comando phpinfo() non noto cambiamenti e trovo sempre la configurazione del file httpd.include.

Il contenuto del mio file vhost.conf è il seguente:

 

<Directory  /var/www/vhosts/dominio.com/httpsdocs/>
php_admin_flag engine on
php_admin_value safe_mode off
php_admin_value open_basedir "/var/www/vhosts/dominio.com/httpdocs:/tmp:/usr/share/pear"
</Directory>

Invece il contenuto del file httpd.include è:

 

# ATTENTION!
# DO NOT MODIFY THIS FILE OR ANY PART OF IT. THIS CAN RESULT IN IMPROPER PLESK
# FUNCTIONING OR FAILURE, CAUSE DAMAGE AND LOSS OF DATA. IF YOU REQUIRE CUSTOM
# MODIFICATIONS TO BE APPLIED TO THE CONFIGURATION, PLEASE, PERFORM THEM IN THE
# FOLLOWING FILE(S):
# /var/www/vhosts/dominio.com/conf/vhost.conf
# /var/www/vhosts/dominio.com/conf/vhost_ssl.conf
# /var/www/vhosts/dominio.com/subdomains/<subdomain-name>/conf/vhost.conf

<IfModule mod_ssl.c>

<VirtualHost 62.149.165.208:443>
       ServerName   dominio.com:443
       ServerAlias  www.dominio.com
       UseCanonicalName Off
       DocumentRoot /var/www/vhosts/dominio.com/httpsdocs
       CustomLog  /var/www/vhosts/dominio.com/statistics/logs/access_ssl_log plesklog
       ErrorLog     /var/www/vhosts/dominio.com/statistics/logs/error_ssl_log
<IfModule mod_userdir.c>
       UserDir /var/www/vhosts/dominio.com/web_users
</IfModule>
       SSLEngine on
       SSLVerifyClient none
       SSLCertificateFile /usr/local/psa/var/certificates/certBGA9894
       <Directory /var/www/vhosts/dominio.com/httpsdocs>
       <IfModule sapi_apache2.c>
               php_admin_flag engine on
               php_admin_flag safe_mode off
               php_admin_value open_basedir "/var/www/vhosts/dominio.com/httpsdocs:/tmp"
       </IfModule>
       <IfModule mod_php5.c>
               php_admin_flag engine on
               php_admin_flag safe_mode off
               php_admin_value open_basedir "/var/www/vhosts/dominio.com/httpsdocs:/tmp"
       </IfModule>
               SSLRequireSSL
               Options -Includes -ExecCGI
       </Directory>
       <Directory /var/www/vhosts/dominio.com/web_users>
       <IfModule sapi_apache2.c>
               php_admin_flag engine off
       </IfModule>
       <IfModule mod_php5.c>
               php_admin_flag engine off
       </IfModule>
       </Directory>
</VirtualHost>

</IfModule>

<VirtualHost 62.149.165.208:80>
       ServerName   dominio.com:80
       ServerAlias  www.dominio.com
       UseCanonicalName Off
       DocumentRoot /var/www/vhosts/dominio.com/httpdocs
       CustomLog  /var/www/vhosts/dominio.com/statistics/logs/access_log plesklog
       ErrorLog   /var/www/vhosts/dominio.com/statistics/logs/error_log
<IfModule mod_userdir.c>
       UserDir /var/www/vhosts/dominio.com/web_users
</IfModule>
       <IfModule mod_ssl.c>
               SSLEngine off
       </IfModule>
       <Directory /var/www/vhosts/dominio.com/httpdocs>
       <IfModule sapi_apache2.c>
               php_admin_flag engine on
               php_admin_flag safe_mode off
               php_admin_value open_basedir "/var/www/vhosts/dominio.com/httpdocs:/tmp"
       </IfModule>
       <IfModule mod_php5.c>
               php_admin_flag engine on
               php_admin_flag safe_mode off
               php_admin_value open_basedir "/var/www/vhosts/dominio.com/httpdocs:/tmp"
       </IfModule>
               Options -Includes -ExecCGI
       </Directory>
       <Directory /var/www/vhosts/dominio.com/web_users>
       <IfModule sapi_apache2.c>
               php_admin_flag engine off
       </IfModule>
       <IfModule mod_php5.c>
               php_admin_flag engine off
       </IfModule>
       </Directory>
       Include /var/www/vhosts/dominio.com/conf/vhost.conf
</VirtualHost>

Qualcuno sa dirmi dove sbaglio e la procedura corretta?

Grazie mille.

Share this post


Link to post
Share on other sites

Ciao, dopo il comando /usr/local/psa/admin/sbin/websrvmng -a -v non è necessario il riavvio di apache, comunque ho risolto il problema con il seguente file vhost.conf:

 

<Directory  /var/www/vhosts/dominio.com/httpdocs/>
php_admin_value safe_mode off
php_admin_value open_basedir "/var/www/vhosts/dominio.com/httpdocs:/tmp:/usr/share/pear"
AllowOverride All
</Directory>

Ora prende le modifiche. Rimane il problema del safe_mode ad off. Vorrei riportarlo ad on, ma per fare ciò penso di dover

utilizzare il file .htaccess, ma non so bene come. Farò delle ricerche con google, ma nel frattempo ogni consiglio e suggerimento è bene accetto.

Grazie.

Share this post


Link to post
Share on other sites

Dove hai letto che dopo /usr/local/psa/admin/sbin/websrvmng -a -v non è necessario riavviare apache? Quel comando serve solo ad includere il nuovo vhost.conf nella configurazione, non fa altro. Dunque dopo occorre un reload o un riavvio di apache per applicarla. Comunque Plesk fa un reload ogni 15 minuti in automatico, forse per questo adesso ti ha accettato le modifiche.

 

Se la versione di Plesk è la 8, puoi impostare il safe_mode direttamente dal pannello, altrimenti la direttiva corretta è

php_admin_flag safe_mode off

Share this post


Link to post
Share on other sites

Devo installare Joomla su un server che ha Plesk 7.5 quindi non posso impostare il Safe mode a OFF da pannello. Creato un file vhost.conf contente soltanto la riga:

 

php_admin_flag safe_mode off

 

salvo, esco, ma quando digito /usr/local/psa/admin/sbin/websrvmng -a -v mi risponde "-bash: websrvmng: command not found

 

eppure il file websrvmng c'è! Non ci capisco più nulla...HELP

Share this post


Link to post
Share on other sites

Si però come detto da Plesk lo puoi fare dalla 8 in poi. Php.ini riguarda tutto il server ed è meglio non toccarlo.

 

Comunque ho risolto eseguendo la riga di comando dalla cartella dove c'è il file vhost.conf magari serve a qualcuno ciao

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×