Jump to content
sbattitene

Aggiornare Server Dedicato da PHP 5.3.3 a PHP 5.3.10 o oltre per aver Joomla 3.x

Recommended Posts

Buongiorno a tutti ed un ringraziamento anticipato a chi mi vorrà e saprà aiutare.

Io mio sito è creato con la versione Joomla 2.5.x e sta su un server unmanaged che ha:

- Parallels Plesk -> v12.0.18_build1200140606.15 os_CentOS 6
- OS -> CentOS 6.5 (Final)

- PHP 5.3.3;

- il servizio Plesk;

- CPU Intel® Core i7 920 @2.67GHz;

- ben 24 gb di ram;

- Banda illimitata.

Spendo 68,59€ al mese (ossia 56,22€+22%iva/mese).

 

La mia volontà è quella di aggiornare il mio sito da Joomla 2.5.x a Joomla 3.x ma per farlo ho bisogno che il mio server passi da un PHP 5.3.3 a un PHP 5.3.10 o superiore (visto che ci siamo meglio direttamente la versione 5.4).

Mi è stato inoltre detto che il CentOS 6.5 non va bene con il PHP 5.3.10 e che la soluzione migliore sia direttamente passare alla versione stabile di CentOS 7 con PHP 5.4.

 

Non sono un sistemista né ho conoscenze sistemiche, sono "solo" un webmaster/webdesigner, quindi ho contattato il mio provider ma dice che loro fanno solo l'installazione al momento dell'acquisto (che è avvenuto più di 2 anni fa) e la gestione della rete.

 

Quanto potrebbe costarmi, e dove trovarlo, un sistemista che - senza cancellarmi e né rovinarmi la perfetta funzionalità del mio portale - possa portarmi il server a CentOS 7 con PHP 5.4?

Grazie in anticipo a tutti

Share this post


Link to post
Share on other sites

Ciao,

 

non è corretto che su CentOS 6 non si possano installare versioni di PHP superiori alle 5.3.

Abbiamo server dove girano PHP 5.4 e 5.5 senza problemi su CentOS 6 con Plesk, tuttavia non mi sento di incoraggiarti a farlo senza l'aiuto di qualcuno che sia esperto, perchè rischi di ritrovarti con un sistema inutilizzabile se non sai come fare.

Share this post


Link to post
Share on other sites

Il salto da centos6 a centos7 con plesk sopra a mio avviso è sconsigliabile (oltre che non necessario)

 

6.5 è vecchia come release e con bugs molto gravi... spero sia un errore di battitura e tu sia all'attuale 6.7...

 

Ho proprio la versione CentOS 6.5 (Final) che, come ho detto, non vorrei più avere perché è obsoleta ed in quanto - (così mi hanno detto!) - il PHP 5.4 ha spesso problemi con il CentOS 6.5 mentre è perfetto con il CentOS 7. Lei conferma ciò?

Ribadisco che io non sono un sistemista (ecco perché vi ho domandato quanto mi costerebbe far fare ad un altro questo upgrade di S.O. e di PHP). Lei cosa mi consiglia?

 

Ciao,

 

non è corretto che su CentOS 6 non si possano installare versioni di PHP superiori alle 5.3.

Abbiamo server dove girano PHP 5.4 e 5.5 senza problemi su CentOS 6 con Plesk, tuttavia non mi sento di incoraggiarti a farlo senza l'aiuto di qualcuno che sia esperto, perchè rischi di ritrovarti con un sistema inutilizzabile se non sai come fare.

 

Non mi hanno detto che è impossibile ma che spesso danno problemi. Veda la risposta che ho dato a EvolutionCrazy. La sua opinione è molto gradita e la ringrazio in anticipo se vorrà ulteriormente ausiliarmi.

Share this post


Link to post
Share on other sites

L'ultima versione di CentOS 6 è la 6.7, non la 6.5.

 

Comunque non abbiamo mai avuto problemi con PHP 5.4 e 5.5 su CentOS 6.x, nè con pacchetti rpm non ufficiali nè ricompilandolo dai sorgenti.

Share this post


Link to post
Share on other sites

L'ultima versione di CentOS 6 è la 6.7, non la 6.5.

 

Comunque non abbiamo mai avuto problemi con PHP 5.4 e 5.5 su CentOS 6.x, nè con pacchetti rpm non ufficiali nè ricompilandolo dai sorgenti.

Continuo a non capire cosa lei mi consiglia di fare e a che costo. Grazie

Share this post


Link to post
Share on other sites

Molto semplicemente di aggiornare il sistema a CentOS 6.7 (non alla versione 7) e, successivamente, aggiornare PHP alla versione desiderata.

Noi non effettuiamo questo tipo di interventi su macchine che non siano nostre, tuttavia questo forum è frequentato da professionisti, per cui non credo ci saranno problemi a reperire un sistemista che possa eseguire questo lavoro. Il costo di un intervento di questo tipo può variare dai 50 ai 150 euro, dipende dal tempo necessario per l'installazione in base alla configurazione corrente.

Share this post


Link to post
Share on other sites

Grazie per la sua risposta.

1) Mi consiglia CentOS 6.7 perché non esiste la versione 7 o perché?

2) Quale è la sezione di questo forum ove mettere l'annuncio?

3) Come posso essere certo che il sistemista non crei problemi al portale?

Grazie tante ancora

Share this post


Link to post
Share on other sites

Grazie per la sua risposta.

1) Mi consiglia CentOS 6.7 perché non esiste la versione 7 o perché?

 

no, esiste la versione 7, ma e' un salto considerevole (cambiano molte cose nel sistema) ed e' consigliabile aggiornare all'ultima release della 6, che risolve un bel po' di cose sul piano della sicurezza e ricevera' ancora aggiornamenti per un bel po' di tempo.

l'aggiornamento di sistema non dovrebbe (a meno di configurazioni particoli e di paturnie di plesk) rompere alcunche', cosi' come l'aggiornamento di php.

 

2) Quale è la sezione di questo forum ove mettere l'annuncio?

 

credo che qua vada bene, ma magari sentiamo qualche moderatore :)

 

3) Come posso essere certo che il sistemista non crei problemi al portale?

Grazie tante ancora

 

il sistemista non ti puo' dare la certezza che il portale continui a funzionare come ci si aspetta dopo l'aggiornamento a PHP 5.4/5.5, in quanto il portale l'hai sviluppato tu e tu dovresti essere a conoscenza di eventuali incompatibilita' con l'interprete.

 

in ogni caso, il consiglio e' quello di prendere un piano managed in modo che sia il provider a doversene preoccupare; certo, pagare l'intervento una tantum e' piu' economico, ma probabilmente e' meno efficace di esser seguiti costantemente.

 

saluti

Share this post


Link to post
Share on other sites

Secondo me la via ideale da percorrere è quella, trovato un sistemista abile ed arruolato, di aggiornare a Centos 6.7, che non dovrebbe comportare nessun problema al sistema in quanto si tratta solo di aggiornamenti a livello bugfix, poi puoi aggiornare php alla 5.4 o 5.5 utilizzando gli RPM di https://webtatic.comma qui, chi ti farà il lavoro, deve fare più attenzione e se ci saranno problemi di compatibilità dovrai essere anche te a verificare lato applicativo se qualcosa va corretto.

 

Nessuno però può darti garanzie a priori, soprattutto se il server non è stato seguito fin dall'inizio dallo stesso tecnico. Come detto da altri il consiglio è passare ad un piano managed dove gli aggiornamente vengono fatti regolarmente.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×