Jump to content
kb8

Insolito problema con protocollo SSL: domini non miei mostrano il mio sito.

Recommended Posts

Ciao a tutti,

 

cerco di spiegarvi l'insolito scenario che mi si è venuto a creare con un dominio.

 

Gestisco un sito su cui è attivo un dominio con relativo protocollo SSL valido e correttamente configurato, come confermato dal provider stesso.

 

Compiendo su Google alcune ricerche ho notato che alcuni siti X restituiscono una serp riconducibile a pagine del mio sito, quindi title e description di pagine del mio sito.

 

Ho ulteriormente notato che tali indirizzi sono https - la corrispettiva controparte http rimanda regolarmente alle loro rispettive pagine - e cercando di accedervi il browser mi avvisa che si tratta di un certificato non valido, tuttavia forzando mi ritrovo effettivamente su una pagina del mio sito ma con url del sito X con protocollo https. 

 

Facendo ulteriori indagini mi sono reso conto che tali siti sono tutti presenti sullo stesso identico server su cui è ospitato il mio.

 

Ho aperto un ticket di assistenza verso il mio provider ma la risposta non mi ha soddisfatto del tutto, adducendo la problematica a Google e il suo algoritmo di ricerca.

 

In qualche maniera il bot di Google avrebbe forzato la connessione https dei siti X - bloccata dal browser - che, avendo dei certificati non validi da come risposta "certificato non valido" indicando poi che il "vicino" di tale(i) host con certificato valido è proprio il mio.  Quindi forzando accede al mio ma ovviamente tramite l'url https dei siti X.

 

Quanto può essere plausibile questo scenario? Ma soprattutto, tale comportamento è corretto e realmente riconducibile ad un "problema" di Google?

 

Grazie mille.  :)

Share this post


Link to post
Share on other sites

Ciao,

Grazie per la risposta.

 

Il sommario generale mi restituisce:

A-
Intermediate certificate has a weak signature. Upgrade to SHA2 as soon as possible to avoid browser warnings.
The server does not support Forward Secrecy with the reference browsers. Grade reduced to A-
 
Non so se è il caso di postare l'intero report, è lunghissimo!
 
Eventualmente posso inserire qui il link del sito tramite google shortlink se non è un problema.

Share this post


Link to post
Share on other sites

Scommetto che NON hai un IP dedicato...

In questo caso probabilmente è un qualche casino a livello di server (per capire esattamente quale servirebbe la sfera di cristallo).

 

Google search console cosa dice? Comincia col verificarlo, e setta la versione corretta da indicizzare (quella con l'https e, a tua scelta, con o senza www)

Poi, partendo dal presupposto che dal tuo fornitore di hosting non riceverai molto supporto (probabilmente non hanno neppure capito il problema), potresti, nell'ordine:

- giocare un po' con il robots.txt e la search console per cercare di eliminare le pagine esterne

- farti assegnare un IP dedicato

- cambiare hosting

 

 

Share this post


Link to post
Share on other sites

Il sito è verificato e configurato correttamente, comunque approfondirò.

 

Per il resto, sì non ho un IP dedicato; circa l'hosting devo dire che fino ad oggi, dopo anni, non ho mai avuto problemi (ho pure altri siti).

 

Adesso ho notato che mi ritrovo pure altri domini su adsense!!!

Share this post


Link to post
Share on other sites

Ho analizzato velocemente il link che mi hai fornito in privato, e ho notato delle incongruenze, se vai su sul tuo dominio utilizzando http e www ci si dovrebbe aspettare che venga fatto il redirect verso la versione https, ma ciò non accade.

Inoltre tu hai un certificato RapidSSL, ergo dovresti avere un'ip dedicato, verifica direttamente con il tuo provider.

Share this post


Link to post
Share on other sites

Ti ringrazio e forse il problema potrebbe essere proprio questo, un certificato che si aspetta un ip dedicato e quindi va ad interessare tutti i siti presenti su quell'ip.

 

Detto questo, mi hanno risposto e in un certo senso "mitigato" il problema.

 

In pratica hanno attivato per tutti gli host presenti sul server il certificato SSL, pertanto adesso forzando qualsiasi host presente sul server verrà forzata la connessione su lo stesso host con protocollo https, in quanto ora presente.

 

Infatti adesso se vado a visitare uno dei link "incriminati" mi restituisce una pagina di errore 404 del provider.

 

Su questo tipo di iniziativa rimango però un po' perplesso: non potrebbero sorgere problemi SEO per tutti i siti presenti sui loro server che ancora non avevano pianificato un utilizzo del protocollo https (risultati ripetuti nelle query di ricerca)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×