Jump to content

Recommended Posts

Salve a tutti :-)

Sul mio Server VPS, basato su CentOS 6.10 e Plesk 17.8.11 mi compare questo messaggio

 

 

Il parametro dello stato del server "Servizi > Utilizzo della memoria Apache" ha cambiato il suo stato da "green" a "yellow".

top - 14:56:39 up 39 days, 3:18, 0 users, load average: 0.00, 0.00, 0.00
Tasks: 98 total, 3 running, 94 sleeping, 0 stopped, 1 zombie
Cpu(s): 2.4%us, 1.0%sy, 0.5%ni, 96.0%id, 0.1%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 4194304k total, 4115036k used, 79268k free, 0k buffers
Swap: 0k total, 0k used, 0k free, 1230124k cached

 


seguito dalla lista dei processi tra cui indico quelli di Apache:
 

2414 apache 20 0 238m 49m 652 S 0.0 1.2 0:03.64 httpd
2415 apache 20 0 239m 53m 2908 S 0.0 1.3 0:06.30 httpd
2622 apache 20 0 239m 53m 2892 S 0.0 1.3 0:06.25 httpd
2790 apache 20 0 239m 53m 2948 S 0.0 1.3 0:06.27 httpd
5196 apache 20 0 239m 53m 2892 S 0.0 1.3 0:05.19 httpd

 

 

 

Dopo alcuni minuti arriva un secondo messaggio che indica che è tutto tornato come prima:

 

 

Il parametro dello stato del server "Servizi > Utilizzo della memoria Apache" ha cambiato il suo stato da "yellow" a "green".

 

 

Se non intervengo con un riavvio, ogni 10 minuti (a volte ogni 20 o 30 minuti) circa arriva il primo avviso "Yellow" e successivamente dopo circa 5 o 10 minuti quello "Green"; Se riavvio il sistema sta buono per un mesetto.

 

Chiaramente il riavvio dell'intera macchina, specie per un server, deve essere l'ultima delle soluzioni, ma ho provato a riavviare solo il servizio Apache, senza però risolvere il problema...

 

 

Ovviamente so che c'è qualche sito che fa aumentare la memoria di Apache, ma secondo me un problema specifico di qualche sito (principalmente sono siti Joomla!, Wordpress e altri statici) perché dopo il riavvio il problema non si presenta più...

 

 

Come potrei intervenire senza dover riavviare per forza il server?

 

Ringrazio Anticipatamente per le Risposte :-)

 

Edit: Con la pubblicazione mi sono reso conto che era sparita la parte iniziale del Messaggio

 

 

Share this post


Link to post
Share on other sites

Ciao,

 

fossi in te disabiiterei lo status monitor di Plesk :)

 

Hai oltre 1 GB di memoria impiegata come cache del sistema (che è una cosa buona) e 0 swap, che ti importa che Plesk ti dica che l'utilizzo della memoria di apache è "yellow"? Non significa nulla, non devi fare nulla, non devi riavviare apache e neanche il VPS...

Share this post


Link to post
Share on other sites

Be in effetti se il plesk utilizza circa il 30% di memoria non è un problema... se non fosse per quella "dannate" email che mi arrivano in continuazione :-D

Se sapessi come fare, modificherei l'avviso al 50% o 70% ;-)

Share this post


Link to post
Share on other sites

Io ti consiglio di disinstallare lo status monitor e di analizzare periodicamente le statistiche che genera watchdog.

Poi, potresti installare "munin", che è decisamente più dettagliato ed utile per l'analisi delle risorse.

Share this post


Link to post
Share on other sites

 se non fosse per quella "dannate" email che mi arrivano in continuazione :-D

 

 

Un opportuno filtro su Thunderbird fa miracoli!!!! :D

 

(mi ricorda tanto un post su un gruppo di appassionati di vecchie Fiat Panda... ad uno, che lamentava che una certa spia gli si accendeva in maniera casuale, fu risposto: "sostituisci la lampadina della spia con una fulminata, ed andrà tutto a posto!" :D )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×