Jump to content
Sign in to follow this  
lele975

Qualcuno può aiutarmi?? Problemi con Metodi POST e GET su VPS

Recommended Posts

Mi scuso fin d'ora se dovessi essere offtopic.

Ho un problema assurdo da cui non riesco ad uscire, spero di trovare qualcuno che possa auitarmi!!!:hammer:

Ho implementato una sezione riservata di un sito in PHP.

C'è una pagina di accesso con un form da compilare per effettuare l'accesso. Questo form invia con metodo POST delle variabili che dovrebbero autenticarmi l'accesso e inizializzare una sessione.

Il problema è che le stesse identiche pagine, montate su un hosting linux di aruba funziona perfettamente, mentre montate su VPS non funzionano non passando i valori POST nè restituendo i GET di fallimento della sessione.

L'errore che restituisce è

Warning: main(conn_.php): failed to open stream: No such file or directory in C:\Inetpub\vhosts\sitcc.it\httpdocs\staffarea\logi n.php on line 14

Warning: main(): Failed opening 'conn_.php' for inclusion (include_path='.;./includes;./pear') in C:\Inetpub\vhosts\sitcc.it\httpdocs\staffarea\logi n.php on line 14

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in C:\Inetpub\vhosts\sitcc.it\httpdocs\staffarea\logi n.php on line 17

 

Il VPS è windows con plesk 7.6. Ho settato tutti i parametri compreso lo scripting PHP. La cosa strana che ho anche provato su un VPS linux, ma niente, stesso problema.

Ho paura che ci sia qualche configuraione del server che mi sfugge, ho anche provato a fare delle modifiche sul php.ini, ma niente.

 

il sito funzionante è su http://www.omniserv.it/sitcc/

lo stesso sito su VPS windows è qui http://www.sitcc.it/staffarea/

mentre lo stesso sito su VPS linux è qui

http://areautenti.sitcc.it/

Spero sia un problema che già qualcuno ha risolto!!!!

Grazie

Share this post


Link to post
Share on other sites

Il file Login.php c'è (non è logi_n.php avevo sbagliato a riportare l'errore...).

La cosa strana è che comunque non mi restituisce neanche le variabili get sulla pagina, ma solo nell'url...Poi quello che mi chiedo è perchè su un hosting base shared funziona perfettamente, mentre su una VPS no?...Per questo pensavo alla configurazione del plesk o del virtuozzo...

Share this post


Link to post
Share on other sites

Scusa NIKY, in che senso?

Da plesk ho effettuato tutti i settaggi richiesti, ho provato in tutti i modi, CGI, ISAPI, permessi di scrittura etc... La cosa che più mi lascia interdetto è che l'ho caricato su un VPS LINUX e neanche lì funziona e mi da gli identici problemi. A questo punto credo non sia un problema di sistema operativo del server, ma di qualche settaggio dello stesso....Mi funziona solo sull'hosting linux normale di Aruba. Allora ho provato a confrontare i PHPINFO() tra VPS e hosting e sono perlopiù identici.

Sto impazzendo, ho aperto anche un ticket su aruba ma nessuna risposta...

Oltretutto ho aperto il php.ini del server e ho trovato u

Se vi viene in mente qualche cosa che potrei controllare o settare dal punto di vista VPS o altro ve ne sarei grato...Grazie...Grazie...Grazie...Grazie...Grazie...Grazie...

Share this post


Link to post
Share on other sites

Ancora non ho risolto. Grazie a tutti comunque per le risposte. Ho verificato sui phpinfo che le path fossero corrette ed ho pure modificato il php.ini per provare a risolvere ma niente (ho pure trovato degli errori nel php.ini installato di default sulla VPS windows). Ho aperto un ticket su aruba e mi hanno risposto che faranno delle verifiche sul mio server quando avranno tempo.

Intanto continuo a provare, anche se mi sembra assurdo che non mi passino i valori post e get di un semplice form...

Grazie ancora a tutti, appena riuscirò a risolvere vi posterò la soluzione. Se nel frattempo a qualcuno viene in mente qualcosa...

Ciao a tutti

Share this post


Link to post
Share on other sites

CIAO A TUTTI! HO RISOLTO!!!!!!!!!

Finalmente dopo giorni e giorni di attesa e numerosi ticket con aruba e invio di moduli etc etc... mi hanno risolto il problema.

Praticamente hanno dovuto chiedere assistenza alla SWsoft che ha risolto. Incollo di seguito la risposta originale che la SWsoft ha inviato, magari potrà essere di aiuto a qualcuno che ha avuto il mio stesso problema.

-------------------------------------------------------------------------

Hello, Sir

 

This issue was caused by the \"register_globals\" option in the php.ini file. On the windows server it was set to the default secure value \"Off\".

Howeverm the variable $sys, which is required to form the proper file name, hasn\'t been evaluated with the values from the POST headers. So, PHP wouldn\'t take this value by default.

Once I opened c:\\windows\\php.ini and set it \"register_globals=On\" -- the script is working as it should.

 

Please, tell if you have any further questions.

-------------------------------------------------------

Praticamente era come immaginavo un settaggio del php.ini che andava modificato.

A presto e grazie del supporto.

Ciao

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×