Jump to content
Sign in to follow this  
framacomputer

IspConfig primi passi - creazione sito

Recommended Posts

avrei bisogno se possibile di avere alcuni chiarimenti..... sono nuovo del forum e praticamente ho installato e configurato un server debian con ispconfig e sono amministratore e vorrei direttamente creare siti senza creare rivenditori e praticamente se creo un sito pippo.it con host www (www.pippo.it) corrispondente all'ip 88.44.55.66 e già registrato su dns del mio provider io vedo che se dal browser vado su www.pippo.it mi viene la pagina di default di apache invece se io scrivo http://www.pippo.it/www.pippo.it/web/ vedo il mio sito web..... ora mi domando non dovrebbe ispconfig fare in automatico tutto questo processo? se abilito ftp in relazione al cliente collegato al sito esempio user web5_pippo mi loggo dal client ftp e vedo la cartella web...... è la stessa che è dentro /var/www/www.pippo.it?

Grazie mille a tutti

Share this post


Link to post
Share on other sites

mmmm credo che sia tutto ok io penso che sia una questione di procedura... oltretutto se io creo un sito dentro /var/www lo crea perfettamente e quando creo un utente dentro var/www mi crea il prefisso es. web2 quindi se creo un cliente ed il sito lui mi crea automaticamente www.prova.it e web2 dentro apache con le solite cartelle e soliti file ma distinti della serie che se modifico index che sta dentro /var/www/web2/web e apro www.prova.it/www.prova.it/web/index.html non è modificato se invece scrivo www.prova.it/web2/web/index.html è modificato. ma se accedo ftp vedo una cartella web e un file index.html che non corrisponde a nessuno dei due citati sopra..... a me sembra assurdo. purtroppo ormai il server è in housing presso un presso un provider e non posso rifare tutto da capo ti posto un immagine della configurazione (in allegato) grazie

post-2108-14246368231023_thumb.jpg

Share this post


Link to post
Share on other sites

io non voglio essere antipatico ma se ti chiedo un file ci sarà un motivo :) ho ben chiaro il problema e voglio capire che errore di scrittura su quel file ha fatto ispconfig

Share this post


Link to post
Share on other sites

ok ci siamo:

 

##################################### ISPConfig vHost Configuration File# Version 1.0#####################################NameVirtualHost 127.0.0.1:80<VirtualHost 127.0.0.1:80> ServerName localhost ServerAdmin root@localhost DocumentRoot /var/www/sharedip</VirtualHost>NameVirtualHost 62.149.210.188:80<VirtualHost 62.149.210.188:80> ServerName localhost ServerAdmin root@localhost DocumentRoot /var/www/sharedip</VirtualHost>######################################### Vhost: www.framacomputer.com:80########################################<VirtualHost 62.149.210.188:80>ServerName http://www.framacomputer.com:80ServerAdmin webmaster@framacomputer.comDocumentRoot /var/www/web10/webDirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htmErrorLog /var/www/web10/log/error.logAlias /error/ "/var/www/web10/web/error/"ErrorDocument 400 /error/invalidSyntax.htmlErrorDocument 401 /error/authorizationRequired.htmlErrorDocument 403 /error/forbidden.htmlErrorDocument 404 /error/fileNotFound.htmlErrorDocument 405 /error/methodNotAllowed.htmlErrorDocument 500 /error/internalServerError.htmlErrorDocument 503 /error/overloaded.htmlAliasMatch ^/~([^/]+)(/(.*))? /var/www/web10/user/$1/web/$3AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web10/user/$1/web/$3</VirtualHost>###

Share this post


Link to post
Share on other sites

ecco come volevasi dimostrare il dominio non è stato scritto tra i vhost di apache quindi non ti funzionerà mai come http://www.prova.it, l'unico dominio scritto e che probabilmente andrà è framacomputer.com.

Prova a cancellare il dominio prova e ricrearlo.

Share this post


Link to post
Share on other sites

Ti posto il nuovo file dei virtual host, ho riconfigurato il tutto eliminando tutto da ispconfig ed ho provato a configurare il sitowww.framacomputer.com ma la pagina che mi compare è quelladi apache2-defaults ho paura che il problema sia di apache.Grazie ##################################### ISPConfig vHost Configuration File# Version 1.0#####################################NameVirtualHost 127.0.0.1:80<VirtualHost 127.0.0.1:80> ServerName localhost ServerAdmin root@localhost DocumentRoot /var/www/sharedip</VirtualHost>NameVirtualHost 62.149.210.188:80<VirtualHost 62.149.210.188:80> ServerName localhost ServerAdmin root@localhost DocumentRoot /var/www/sharedip</VirtualHost>######################################### Vhost: www.framacomputer.com:80########################################<VirtualHost 62.149.210.188:80>ServerName http://www.framacomputer.com:80ServerAdmin webmaster@framacomputer.comDocumentRoot /var/www/web11/webServerAlias framacomputer.comDirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htmErrorLog /var/www/web11/log/error.logAlias /error/ "/var/www/web11/web/error/"ErrorDocument 400 /error/invalidSyntax.htmlErrorDocument 401 /error/authorizationRequired.htmlErrorDocument 403 /error/forbidden.htmlErrorDocument 404 /error/fileNotFound.htmlErrorDocument 405 /error/methodNotAllowed.htmlErrorDocument 500 /error/internalServerError.htmlErrorDocument 503 /error/overloaded.htmlAliasMatch ^/~([^/]+)(/(.*))? /var/www/web11/user/$1/web/$3AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web11/user/$1/web/$3</VirtualHost>###

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×