Jump to content
Sign in to follow this  
iettafune

aggiornare server con yum update..funziona??

Recommended Posts

raga, ho installato sul mio vps da tempo yum..... mi era stato detto che avviando il comando yum update in auto avrebbe controllato tutti i pacchetti installati sul server e se ci fosse una nuova versione la rileva e chiede di installarla...

 

mi era stato detto che teneva sotto controllo anche php, mysql ecc....

 

eppure non lo fa..perchè io ho una versione piu vecchia delle ultime sia di php che di mysql...

 

come mai??

 

grazie

Share this post


Link to post
Share on other sites

Lo sai che redhat e derivate non cambiano mai le versioni dei pacchetti principali ma le patchano soltanto vero?

 

Ossia, se hai php 4.3.9, rimarrà 4.3.9 anche se lo aggiorni, ma con le patch di sicurezza ed i bugfix.

 

Se è questo quello che succede, è normale, a meno che yum invece non ti risponda con degli errori, ma quella è un'altra storia...

Share this post


Link to post
Share on other sites

io ho un vps con procerrose amd64 e SO centos.... controllado ho php 5.1.6 e mysql 5.0.22 ma controllando nei siti dei produttori le ultime release sono php 5.2.5 e per mysql non ricordo ma la mia non è l'ultima...

 

e avviando yum update non mi trova gli aggiornamenti di questi due pacchetti...

Share this post


Link to post
Share on other sites

le release dei pacchetti sono sempre più vechie delle ultime versioni ufficiali. Se vuoi aggiornare all'ultimissima versione devi andare con i sorgenti e compilarteli (che in fondo è sempre la cosa migliore).

Inoltre gli aggiornamenti riguardano sono aspetti di sicurezza e bug-fix

Share this post


Link to post
Share on other sites
controllado ho php 5.1.6 e mysql 5.0.22 ma controllando nei siti dei produttori le ultime release sono php 5.2.5 e per mysql non ricordo ma la mia non è l'ultima...

E' esattamente quello che ho detto io prima, CentOS è infatti derivata RedHat.

Rimarranno queste versioni probabilmente a vita, i nuovi pacchetti saranno php-5.1.6-2, php-5.1.6-3, etc.

Share this post


Link to post
Share on other sites

mmmm avendo php 5.1.6 e mysql 5.0.22 mi conviene aggiornare alle ultime???

 

anche perchè a quanto pare se ho letto bene a breve uscita vbulletin 3.7.0 ufficiale e ho letto che vuole come minimo php 5.2.5 mmmmm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×