Jump to content
Sign in to follow this  
webs86

Problema apache2 e mod_fastcgi + python

Recommended Posts

ciao a tutti... ho un piccolo problema: ho installato sulla mia macchina locale apache2 con il mod_fastcgi per poter eseguire file python, solo che al posto di eseguirmeli me li fa scaricare... quale può essere il problema? grazie mille...

Share this post


Link to post
Share on other sites
il fatto è che è già installato... non è che oltra ad installarlo devo pure inserire qualche riga di configurazione?

 

Non conosco mod_python ma 10 a 1 devi inserire qualcosa di sto tipo in httpd.conf:

 

AddType application/x-httpd-php .php

 

in pratica la riga sopra dice di associare il file .php come application/x-httpd-php e quindi saranno processati dal PHP.

 

In python molto probabilmente dovrai fare lo stesso cambiando sia estensione che content type.

Share this post


Link to post
Share on other sites

Non conosco webmin e non sapendo che OS stai usando faccio fatica a dirti dove andare a guardare ma cosi' ad occhio direi che se le vedi abilitato allora apache lo sta caricando. Hai provato come suggerito da Guest? Sei sicuro che dell'estensione che deve avere lo script python? Ha i permessi a posto per poter essere eseguito?

Giusto per capire un po' di piu'. Se hai altre info che pensi possano essere utili dille direttamente.

EDIT: Python e' installato nella macchina vero?

EDIT2: prova a leggere qua questa doc

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×