Jump to content
Sign in to follow this  
giagi

ISPConfig: lo sconfiguratore mascherato!

Recommended Posts

Salve ragazzi,

Ieri sera dal pannello ho modificato una password per un acesso ftp e salvando mi si è sputtanato (pardon sconfigurato) apache2 e non voleva partire per nessun motivo.

 

cercando di capire cosa fosse successo, ho trovato alcuni warn di apache tipo questo:

Sun Aug 17 17:55:52 2008] [warn] NameVirtualHost xx.xx.xx.xx.:80 has no VirtualHosts

...fail!

 

ma non è questo il problema perhè adesso parte ma mi la lo stesso errore.

 

per risolvere momentaneamente ho eliminato il file Vhost_ispconfig e apache è partito, ovvimanete senza poter videre i Vhost.

 

allora ho ricaricato manualmente i vhost nel file e a uno a uno sono ripartiti.

 

adesso però se faccio delle modifiche via ISPCONFIG mi ri sputtana tutto!!!

anche se a vista è tutto in ordine nel file, l'unica differenza è questo all'inizio del file:

NameVirtualHost xxxxxxx:80

<VirtualHost xxxxxxx:80>

ServerName localhost

ServerAdmin root@localhost

DocumentRoot /var/www/sharedip

<IfModule mod_rewrite.c>

RewriteEngine on

RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)

RewriteRule .* - [F]

</IfModule>

</VirtualHost>

 

ma non credo sia questo a dare errore.

 

Qualcuno sa dirmi cosa puo essere successo?

Grazie a tutti e spero comunque possa servire anche a qualcunaltro che potrebbe trovarsi con questa bella tegola sulla testa senza colpa (almeno apparente).

 

ciao.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×