Jump to content
Sign in to follow this  
xnavigator

per esperti di server email, funzionano tutte le email tranne una

Recommended Posts

praticamente ho un server dedicato in UK. la gestione del nome del dominio è con gandi società francese.

 

sul pannello di gandi ho inserito i vari record A per far puntare il nome del dominio al server e fin qui tutto bene.

 

Ovviamente in questo caso la gestione delle email personali e cioè mail@nomedominio.com è affidata a gandi.

 

ma se provo ad inviare una mail dal server in uk con la semplice funzione mail sul mio account di posta gandi questa non arriva..

 

tutte le altre email inviate/ricevute sull'account gandi e inviate dal server UK funzionano normalmente...

 

ho scritto al supporto ma non sono riuciti ancora a risolverlo...

 

(ovviametne voi vi chiederete che te le invii a fare le mail dal tuo server alla tua posta, può servire per cose del tipo le cron job per vedere i risultati e altre stupidaggini varie)

 

grazie per l'aiuto

Share this post


Link to post
Share on other sites

Se fossi cattivo ti chiederei dove vai a vedere i log degli errori php :emoticons_dent2020:

Però non sono cattivo... dove prenderli dipende un pò dalla distribuzione e da eventuali pannelli installati che potrebbero dirottare i log, comunque solitamente nella cartella /var/log ci sono i log... e ce ne sono certi che hanno un mail nel nome, per esempio in debian mail.log mail.info mail.err

 

Per fare una cosa mirata ti tieni aperta una shell, mandi una mail nel modo che di solito fa cilecca e poi in shell digiti qualcosa tipo:

tail /var/log/mail.log

 

Questo ti da le ultime 25 righe del file mail.log anche se per assurdo tu abbia un log di 200mb, le ultime righe devono contenere senz'altro le ultime mail mandate, tra cui quella che hai inviato per test.

Da li puoi vedere quale è il problema.

 

 

Adesso non fare il furbo e non darmi la sorella più brutta :emoticons_dent2020:

 

 

P.s. visto che cerco di aiutarti devi concedermi l'ironia: bella idea prendere un server dedicato senza neanche sapere dove sono i log :ciapet:

Share this post


Link to post
Share on other sites

gli errori php lo so bene dove sono perchè ho cambiato io la directory nel php.ini :D

 

comunque effettivamente penso che abbiamo (hai :D ) trovato subito l'errore..

sono andato a vedere i log delle email, in questo caso si trovavano in /var/log/exim4/mainlog (all'interno della cartella exim4 si trovano anche archivi numerati .gz, presumo siano i logrotate)

 

penso di aver trovato la riga incriminata:

 

2008-12-05 16:10:39 1L8cKF-0004w0-Bp ** mioaccountsugandi@miosito.com R=dnslookup T=remote_smtp: SMTP error from remote mail server after RCPT TO:<mioaccountsugandi@miosito.com>: host spool.mail.gandi.net [217.70.184.6]: 550 5.1.8 <www-data@serverxxxxx.uk2net.com.uk2net.com>: Sender address rejected: Domain not found

 

ora il problema è capire cosa significa :D

 

aspetto in pvt l'indirizzo.. cosi ti inizio a spedire la prima sorella :D

 

per il server dedicato: se ho problemi gravi uso bobcares.com (come suggeritomi stesso qui ;) )

 

[forse ho trovato una risposta...

http://www.gossamer-threads.com/lists/exim/users/63864

 

ma non saprei proprio cosa fare lo stesso :D ]

Share this post


Link to post
Share on other sites

Significa che il server che riceve verifica il dominio che invia e trova un errore, cioè il server che nell'intestazione della mail è dichiarato non corrisponde a quello da cui effettivamente parte la mail, quindi non l'accetta.

 

www-data@serverxxxxx.uk2net.com.uk2net.com

 

questo è l'errore... bisognerebbe capire dove hai infilato due volte il dominio

Share this post


Link to post
Share on other sites
questo è l'errore... bisognerebbe capire dove hai infilato due volte il dominio

 

in che senso? non capisco...

 

forse come ti ho detto sopra l'errore deriva dal fatto che la gestione della mia casella di posta e del dominio (dns) è affidata a gandi...

 

e il server ad un'altra società...

 

(ti ripeto che comunque tutte le altre email funzionano... cioè solo questo particolare caso non funziona... dal mio server alla mia mail )

Share this post


Link to post
Share on other sites

Nel senso che mi pare strano www-data@serverxxxxx.uk2net.com.uk2net.com

 

Può essere che uk2net.com sia ripetuto due volte, ma mi sembra strano.

 

In ogni caso da una parte il tuo server mail è chiamato in un modo e da un'altra parte in un'altra.

A me faceva una cosa simile con libero e solo per le mail che partivano dal php, ho ricontrollato che nome host, dns mx, main.cf di postfix e tutto il resto dichiarassero la stessa cosa e mi sono accorto dell'inghippo capitato con il recente cambio server.

Però il dominio ripetuto due volte potrebbe sembrare anche un errore nello script php..

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×